Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#59214 closed defect (duplicate)

Build failure poppler-0.81.0_0.

Reported by: murrayE Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc:
Port: poppler

Description

I'm seeing the same, or similar, build failure with Xcode 11.0 (under macOS 10.14.6) with poppler-0.81.0_0. From the log:

:info:build clang: warning: no such sysroot directory: '/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.14.sdk' [-Wmissing-sysroot]
:info:build In file included from /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_graphics_poppler/poppler/work/build/glib/tmp-introspectt6pqsio6/Poppler-0.18.c:2:
:info:build In file included from /opt/local/include/glib-2.0/glib.h:30:
:info:build In file included from /opt/local/include/glib-2.0/glib/galloca.h:32:
:info:build /opt/local/include/glib-2.0/glib/gtypes.h:35:10: fatal error: 'time.h' file not found
:info:build #include <time.h>
:info:build          ^~~~~~~~
:info:build 1 error generated.
:info:build Traceback (most recent call last):
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/3.7/lib/python3.7/distutils/unixccompiler.py", line 118, in _compile
:info:build     extra_postargs)

Note the line showing "MacOSX10.14.sdk. With Xcode 11.0, there is indeed no such folder. Instead, in

Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs

a link "MacOSX10.15.sdk" whose target is the folder MacOSX.sk in the above-mentioned Xcode folder.

Change History (4)

comment:1 Changed 14 months ago by mf2k (Frank Schima)

In the future, please add the port maintainer(s) to Cc (port info --maintainers poppler), if any.

comment:2 Changed 14 months ago by mf2k (Frank Schima)

Keywords: build failure xcode removed
Owner: set to dbevans
Port: poppler added; poppler-0.81 removed
Status: newassigned

comment:3 Changed 14 months ago by mf2k (Frank Schima)

Resolution: duplicate
Status: assignedclosed

Duplicate of #59078.

comment:4 Changed 14 months ago by murrayE

After I submitted the post, I realized I had forgotten to cc the maintainer, dbevans. When I tried to change it and add him/her, I could not see a place to do so.

Note: See TracTickets for help on using tickets.