#59264 closed defect (duplicate)

py36-pyobjc fails to build on macOS 10.15 Catalina

Reported by: gjaeger (Gregor Jäger) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.1
Keywords: Cc:
Port: py-pyobjc

Description

Error: Failed to build py36-pyobjc: command execution failed

:info:build 2 warnings and 2 errors generated.
:info:build error: command '/usr/bin/clang' failed with exit status 1
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-pyobjc/py36-pyobjc/work/pyobjc-core-5.2" && /opt/local/Library/Frameworks/Python.framework/Versions/3.6/bin/python3.6 setup.py --no-user-cfg build
:info:build Exit code: 1
:error:build Failed to build py36-pyobjc: command execution failed
:debug:build Error code: CHILDSTATUS 2632 1
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_python_py-pyobjc/py36-pyobjc/main.log for details.

Change History (1)

comment:1 Changed 14 months ago by jmroot (Joshua Root)

Port: py-pyobjc added; py36-pyobjc removed
Resolution: duplicate
Status: newclosed

The log snippet doesn't contain any useful information (please attach complete logs), but I'll assume this is a duplicate of #59194.

Note: See TracTickets for help on using tickets.