Opened 15 years ago

Closed 14 years ago

#6012 closed defect (fixed)

BUG: fortune doesn't build, wrong checksums

Reported by: olaf@… Owned by: tobypeterson
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: joelmichael@…, j.van_den_hoff@…, markd@…, barbucha@…, bugzilla@…, fommil@…
Port:

Description

Hi,

I've tried to build fortune :

$ sudo port install fortune ---> Fetching fortune ---> Attempting to fetch fortune-4.6.2-RELEASE.tar.bz2 from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch fortune-starwars.tgz from http://www.splitbrain.org/Fortunes/starwars/ ---> Attempting to fetch fortune-hitchhiker.tgz from http://www.splitbrain.org/Fortunes/hitchhiker/ ---> Attempting to fetch fortune-fgump.tgz from http://www.splitbrain.org/Fortunes/fgump/ ---> Attempting to fetch fortune-xfiles.tgz from http://www.splitbrain.org/Fortunes/xfiles/ ---> Attempting to fetch fortune-mod-futurama-0.2.tar.gz from http://www.netmeister.org/apps/ ---> Attempting to fetch fortune-mod-calvin-0.1.1.tar.gz from http://www.netmeister.org/apps/ ---> Attempting to fetch homer-quotes.tar.gz from http://www.cs.indiana.edu/~crcarter/homer/ ---> Attempting to fetch ralph-quotes.tar.gz from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch cbg-quotes.tar.gz from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch fortune-simpsons-chalkboard.tgz from http://www.splitbrain.org/Fortunes/simpsons/ ---> Attempting to fetch farscape-quotes.tar.gz from http://homepage.mac.com/css/code ---> Verifying checksum(s) for fortune Error: Checksum (md5) mismatch for fortune-starwars.tgz Error: Checksum (md5) mismatch for fortune-hitchhiker.tgz Error: Checksum (md5) mismatch for fortune-fgump.tgz Error: Checksum (md5) mismatch for fortune-xfiles.tgz Error: Checksum (md5) mismatch for fortune-simpsons-chalkboard.tgz Error: Target com.apple.checksum returned: Unable to verify file checksums

Attachments (2)

Portfile (5.3 KB) - added by gertce@… 15 years ago.
Portfile with fixed urls
Portfile.2 (1.8 KB) - added by joelmichael@… 15 years ago.
Portfile for fortune without the extras

Download all attachments as: .zip

Change History (13)

comment:1 Changed 15 years ago by mww@…

Summary: fortune doesn't build, wrong checksumsBUG: fortune doesn't build, wrong checksums

comment:2 Changed 15 years ago by blb@…

Cc: j.van_den_hoff@… added

* Bug 6346 has been marked as a duplicate of this bug. *

Changed 15 years ago by gertce@…

Attachment: Portfile added

Portfile with fixed urls

comment:3 Changed 15 years ago by igloo@…

The five offending files are all at www.splitbrain.org. Their content isn't indispensble. Perhaps they should just be omitted?

comment:4 Changed 15 years ago by blb@…

Cc: barbucha@… added

* Bug 7159 has been marked as a duplicate of this bug. *

comment:5 Changed 15 years ago by bugzilla@…

Cc: bugzilla@… added

comment:6 Changed 15 years ago by fommil@…

(In reply to comment #2)

Created an attachment (id=5578) [edit] Portfile with fixed urls

I haven't tested this patch personally, but I am having the same problem and manual downloading of the files from the new locations fixed it... this bug has been active for over 4 months, blocks the build and a patch exits; how come a fix has not been released?

comment:7 Changed 15 years ago by fommil@…

Cc: fommil@… added

comment:8 Changed 15 years ago by joelmichael@…

Cc: joelmichael@… added

(In reply to comment #3)

The five offending files are all at www.splitbrain.org. Their content isn't indispensble. Perhaps they should just be omitted?

I agree, I don't see any reason for these extra additions to be included. I'd rather just have the vanilla fortune install than super pop culture geek quote edition. if you must have them, make variants?

Changed 15 years ago by joelmichael@…

Attachment: Portfile.2 added

Portfile for fortune without the extras

comment:9 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: duplicate
Status: newclosed

This was fixed in bug 8037.

* This bug has been marked as a duplicate of 8037 *

comment:10 Changed 14 years ago by markd@…

Resolution: duplicate
Status: closedreopened

My mistake, this is not fixed,

comment:11 Changed 14 years ago by markd@…

Resolution: fixed
Status: reopenedclosed

Ok, I removed the extras and it installs now. Thanks!

Note: See TracTickets for help on using tickets.