Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#60370 closed defect (fixed)

py27-hypothesis @5.10.0: build fails, python too old

Reported by: dbevans (David B. Evans) Owned by: kurthindenburg (Kurt Hindenburg)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: py-hypothesis

Description (last modified by dbevans (David B. Evans))

As of version 5.0.0, py-hypothesis only supports python35+.

Since there are a good number of ports that depend on py27-hypothesis, I suggest, rather than remove the py27 subport, that you pin it to the last version that still supports python27 (4.57.1)

See https://github.com/HypothesisWorks/hypothesis/releases/tag/hypothesis-python-5.0.0

Change History (5)

comment:1 Changed 6 months ago by dbevans (David B. Evans)

Description: modified (diff)

comment:2 Changed 6 months ago by dbevans (David B. Evans)

Description: modified (diff)

comment:3 Changed 6 months ago by kurthindenburg (Kurt Hindenburg)

Thanks, missed that obviously - I'll fix tomorrow

comment:4 Changed 6 months ago by Kurt Hindenburg <kurt.hindenburg@…>

Resolution: fixed
Status: assignedclosed

In ec91927339d8826064237a07d50e6b91e1db97be/macports-ports (master):

py-hypothesis: For python27, downgrade to the latest 4+ version

The 5+ versions only supports python3+

https://github.com/HypothesisWorks/hypothesis/releases/tag/hypothesis-python-5.0.0

closes #60370

comment:5 Changed 6 months ago by dbevans (David B. Evans)

Thanks for the quick fix.

Note: See TracTickets for help on using tickets.