Opened 6 months ago

Closed 3 months ago

Last modified 3 months ago

#60390 closed defect (fixed)

lilypond 2.20 cannot be configured

Reported by: trg818 (Thomas Ruedas) Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: lilypond

Description

In the course of running a "port upgrade outdated", it was attempted to upgrade lilypond to 2.20, but this fails at the configure stage, apparently due to some library problem. I uninstalled, cleaned, and reinstalled, but that didn't help.

Attachments (1)

config.log (99.6 KB) - added by trg818 (Thomas Ruedas) 6 months ago.
Logfile from configure/compilation attempt

Download all attachments as: .zip

Change History (6)

Changed 6 months ago by trg818 (Thomas Ruedas)

Attachment: config.log added

Logfile from configure/compilation attempt

comment:1 Changed 6 months ago by mf2k (Frank Schima)

In the future, please add the port maintainer(s) to Cc (port info --maintainers lilypond), if any.

comment:2 Changed 6 months ago by mf2k (Frank Schima)

Keywords: Mojave (OS X 10.14.6) Xcode 10.3 removed
Owner: set to nerdling
Status: newassigned

comment:3 Changed 4 months ago by nerdling (Jeremy Lavergne)

When I try to build it, I get these missing dependencies:

xelatex pdflatex lh CTAN package (texlive-lang-cyrillic or texlive-texmf-fonts) pngtopnm convert

comment:4 Changed 3 months ago by nerdling (Jeremy Lavergne)

Resolution: fixed
Status: assignedclosed

I've slapped the missing dependencies in for what amounts to a +docs build. This now builds for me.

comment:5 Changed 3 months ago by nerdling (Jeremy Lavergne)

In a3fdc4321b52f98cbb08a78dfffb6194b5239d9b/macports-ports (master):

lilypond-devel: upgrade and add missing deps

  • Upgrade to 2.21.4
  • Fixes #60390
Note: See TracTickets for help on using tickets.