Opened 6 months ago

Closed 6 months ago

#60392 closed defect (fixed)

uhd @3.15.0.0_2: Downloader raised an unhandled exception: HTTPConnectionPool(host='127.0.0.1', port=5683): Max retries exceeded with url:

Reported by: nero152 (Glen Roberts) Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: uhd

Description

I have a fresh install of MacPorts on my MacBook Pro, which is running Catalina (version 10.15.4). Prior to installing MacPorts, I followed all of the prerequisites like verifying that I have xcode and xcode command line tools, as well as acknowledging the license.

When I tried to install gnuradio, I received an error regarding uhd. I have attached the error log. Any assistance would be greatly appreciated.

Attachments (1)

MacPorts_GNURadio_UHD_install_error.txt (2.3 MB) - added by nero152 (Glen Roberts) 6 months ago.
UHD error log

Change History (13)

Changed 6 months ago by nero152 (Glen Roberts)

UHD error log

comment:1 Changed 6 months ago by nero152 (Glen Roberts)

Summary: UHD install error while installing gnuradio on mac catalineUHD install error while installing gnuradio on mac catalina

comment:2 Changed 6 months ago by ryandesign (Ryan Schmidt)

Owner: set to michaelld
Port: uhd added
Status: newassigned
Summary: UHD install error while installing gnuradio on mac catalinauhd @3.15.0.0_2:
Version: 2.6.2

The relevant part of the attached log is:

:info:destroot [DEBUG] URLs to download:
:info:destroot x3xx/fpga-fde2a94eb/x3xx_x310_fpga_default-gfde2a94e.zip
:info:destroot x3xx/fpga-fde2a94eb/x3xx_x300_fpga_default-gfde2a94e.zip
:info:destroot e3xx/fpga-fde2a94eb/e3xx_e310_sg1_fpga_default-gfde2a94e.zip
:info:destroot e3xx/fpga-fde2a94eb/e3xx_e310_sg3_fpga_default-gfde2a94e.zip
:info:destroot e3xx/fpga-fde2a94eb/e3xx_e320_fpga_default-gfde2a94e.zip
:info:destroot n3xx/fpga-fde2a94eb/n3xx_n310_fpga_default-gfde2a94e.zip
:info:destroot n3xx/fpga-fde2a94eb/n3xx_n300_fpga_default-gfde2a94e.zip
:info:destroot n3xx/fpga-fde2a94eb/n3xx_n320_fpga_default-gfde2a94e.zip
:info:destroot b2xx/fpga-fde2a94eb/b2xx_b200_fpga_default-gfde2a94e.zip
:info:destroot b2xx/fpga-fde2a94eb/b2xx_b200mini_fpga_default-gfde2a94e.zip
:info:destroot b2xx/fpga-fde2a94eb/b2xx_b210_fpga_default-gfde2a94e.zip
:info:destroot b2xx/fpga-fde2a94eb/b2xx_b205mini_fpga_default-gfde2a94e.zip
:info:destroot b2xx/uhd-2bdad498/b2xx_common_fw_default-g2bdad498.zip
:info:destroot usrp2/fpga-6bea23d/usrp2_usrp2_fw_default-g6bea23d.zip
:info:destroot usrp2/fpga-6bea23d/usrp2_usrp2_fpga_default-g6bea23d.zip
:info:destroot usrp2/fpga-6bea23d/usrp2_n200_fpga_default-g6bea23d.zip
:info:destroot usrp2/fpga-6bea23d/usrp2_n200_fw_default-g6bea23d.zip
:info:destroot usrp2/fpga-6bea23d/usrp2_n210_fpga_default-g6bea23d.zip
:info:destroot usrp2/fpga-6bea23d/usrp2_n210_fw_default-g6bea23d.zip
:info:destroot n230/fpga-fde2a94eb/n230_n230_fpga_default-gfde2a94e.zip
:info:destroot usrp1/fpga-6bea23d/usrp1_usrp1_fpga_default-g6bea23d.zip
:info:destroot usrp1/fpga-6bea23d/usrp1_b100_fpga_default-g6bea23d.zip
:info:destroot usrp1/fpga-6bea23d/usrp1_b100_fw_default-g6bea23d.zip
:info:destroot octoclock/uhd-14000041/octoclock_octoclock_fw_default-g14000041.zip
:info:destroot usb/uhd-14000041/usb_common_windrv_default-g14000041.zip
:info:destroot [ERROR] Downloader raised an unhandled exception: HTTPConnectionPool(host='127.0.0.1', port=5683): Max retries exceeded with url: http://files.ettus.com/binaries/cache/x3xx/fpga-fde2a94eb/x3xx_x310_fpga_default-gfde2a94e.zip (Caused by ProxyError('Cannot connect to proxy.', NewConnectionError('<urllib3.connection.HTTPConnection object at 0x10ba79410>: Failed to establish a new connection: [Errno 61] Connection refused')))
:info:destroot You can run this again with the '--verbose' flag to see more information
:info:destroot If the problem persists, please email the output to: support@ettus.com
:info:destroot Command failed: /opt/local/Library/Frameworks/Python.framework/Versions/3.7/bin/python3.7 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_uhd/uhd/work/destroot/opt/local/share/uhd/utils/uhd_images_downloader.py --verbose --install-location=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_uhd/uhd/work/destroot/opt/local/share/uhd/images
:info:destroot Exit code: 1

Accessing that failed URL in a browser works for me. Maybe there was a temporary server problem on their end. You could try again.

This also points out a bug in the uhd port: it tries to fetch things at destroot time. Ports should only fetch during the fetch phase, and should ideally do so by using the standard MacPorts machinery for fetching.

comment:3 Changed 6 months ago by ryandesign (Ryan Schmidt)

Summary: uhd @3.15.0.0_2:uhd @3.15.0.0_2: Downloader raised an unhandled exception: HTTPConnectionPool(host='127.0.0.1', port=5683): Max retries exceeded with url:

comment:4 Changed 6 months ago by michaelld (Michael Dickens)

@nero152 : The internet path to the images server comes and goes depending on where you are accessing it from in the world; it is, broadly speaking, fairly reliable inside the USA, and less so internationally. The most reliable path forward is to just try the install again ("sudo port install uhd"); both "cmake" and the images downloader will pick up where they left off, overwriting files if/as necessary. If that fails, you can always clean the install ("sudo port clean uhd") and try it again.

comment:5 Changed 6 months ago by michaelld (Michael Dickens)

@ryandesign : I agree that downloading files in the "fetch" phase is ideal. It works for the vast vast vast majority of ports. I've never found a -reliable- way to get it to work with UHD. For UHD to work properly, it requires these images. The images are traditionally fetched once UHD is installed, by the images downloader, to make sure they are compatible with the just-installed UHD; incompatible images are checked for during runtime, and UHD will not function if the images aren't compatible. I will look into this issue again, as it's been a while & maybe things have changed & hence it might be doable without too much challenge to get the inventory file & then download the images. No guarantees.

comment:6 Changed 6 months ago by nero152 (Glen Roberts)

@michealld : I tried to install uhd again after issuing the "sudo port clean uhd" command. Same error... I tried navigating to the listed URL (http://files.ettus.com/binaries/cache/x3xx/fpga-fde2a94eb/x3xx_x310_fpga_default-gfde2a94e.zip) from a browser and the connection was refused from there as well.

However, if I issue a wget command for the URL, I am able to download the zip file.

:info:destroot [DEBUG] URLs to download: :info:destroot x3xx/fpga-fde2a94eb/x3xx_x310_fpga_default-gfde2a94e.zip :info:destroot x3xx/fpga-fde2a94eb/x3xx_x300_fpga_default-gfde2a94e.zip :info:destroot e3xx/fpga-fde2a94eb/e3xx_e310_sg1_fpga_default-gfde2a94e.zip :info:destroot e3xx/fpga-fde2a94eb/e3xx_e310_sg3_fpga_default-gfde2a94e.zip :info:destroot e3xx/fpga-fde2a94eb/e3xx_e320_fpga_default-gfde2a94e.zip :info:destroot n3xx/fpga-fde2a94eb/n3xx_n310_fpga_default-gfde2a94e.zip :info:destroot n3xx/fpga-fde2a94eb/n3xx_n300_fpga_default-gfde2a94e.zip :info:destroot n3xx/fpga-fde2a94eb/n3xx_n320_fpga_default-gfde2a94e.zip :info:destroot b2xx/fpga-fde2a94eb/b2xx_b200_fpga_default-gfde2a94e.zip :info:destroot b2xx/fpga-fde2a94eb/b2xx_b200mini_fpga_default-gfde2a94e.zip :info:destroot b2xx/fpga-fde2a94eb/b2xx_b210_fpga_default-gfde2a94e.zip :info:destroot b2xx/fpga-fde2a94eb/b2xx_b205mini_fpga_default-gfde2a94e.zip :info:destroot b2xx/uhd-2bdad498/b2xx_common_fw_default-g2bdad498.zip :info:destroot usrp2/fpga-6bea23d/usrp2_usrp2_fw_default-g6bea23d.zip :info:destroot usrp2/fpga-6bea23d/usrp2_usrp2_fpga_default-g6bea23d.zip :info:destroot usrp2/fpga-6bea23d/usrp2_n200_fpga_default-g6bea23d.zip :info:destroot usrp2/fpga-6bea23d/usrp2_n200_fw_default-g6bea23d.zip :info:destroot usrp2/fpga-6bea23d/usrp2_n210_fpga_default-g6bea23d.zip :info:destroot usrp2/fpga-6bea23d/usrp2_n210_fw_default-g6bea23d.zip :info:destroot n230/fpga-fde2a94eb/n230_n230_fpga_default-gfde2a94e.zip :info:destroot usrp1/fpga-6bea23d/usrp1_usrp1_fpga_default-g6bea23d.zip :info:destroot usrp1/fpga-6bea23d/usrp1_b100_fpga_default-g6bea23d.zip :info:destroot usrp1/fpga-6bea23d/usrp1_b100_fw_default-g6bea23d.zip :info:destroot octoclock/uhd-14000041/octoclock_octoclock_fw_default-g14000041.zip :info:destroot usb/uhd-14000041/usb_common_windrv_default-g14000041.zip :info:destroot [ERROR] Downloader raised an unhandled exception: HTTPConnectionPool(host='127.0.0.1', port=5683): Max retries exceeded with url: http://files.ettus.com/binaries/cache/x3xx/fpga-fde2a94eb/x3xx_x310_fpga_default-gfde2a94e.zip (Caused by ProxyError('Cannot connect to proxy.', NewConnectionError('<urllib3.connection.HTTPConnection object at 0x1054c6610>: Failed to establish a new connection: [Errno 61] Connection refused'))) :info:destroot You can run this again with the '--verbose' flag to see more information :info:destroot If the problem persists, please email the output to: support@… :info:destroot Command failed: /opt/local/Library/Frameworks/Python.framework/Versions/3.7/bin/python3.7 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_uhd/uhd/work/destroot/opt/local/share/uhd/utils/uhd_images_downloader.py --verbose --install-location=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_uhd/uhd/work/destroot/opt/local/share/uhd/images :info:destroot Exit code: 1 :error:destroot Failed to destroot uhd: command execution failed :debug:destroot Error code: NONE :debug:destroot Backtrace: command execution failed :debug:destroot while executing :debug:destroot "$post $targetname" :error:destroot See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_science_uhd/uhd/main.log for details.

Last edited 6 months ago by nero152 (Glen Roberts) (previous) (diff)

comment:7 Changed 6 months ago by michaelld (Michael Dickens)

Can you try the URL directly again but using "https" instead of "http"?

Both work for me, but we've seen some OSs have networking issues when using the latter. I believe this behaviour is fixed (all moved to the former) in the next UHD release.

Last edited 6 months ago by michaelld (Michael Dickens) (previous) (diff)

comment:8 Changed 6 months ago by nero152 (Glen Roberts)

When using a web browser, I am able to download the zip using "https", not "http". With the terminal, I can download both.

comment:9 Changed 6 months ago by michaelld (Michael Dickens)

Excellent. Let me see about adding that fix into the current UHD port ... it should take care of the issue!

comment:10 Changed 6 months ago by michaelld (Michael Dickens)

Added in < https://github.com/macports/macports-ports/commit/93b27caf80c138765d30a96d4b96d2c36bd1014a >. Please update your ports and try installing UHD again & hopefully this will do the trick!

comment:11 Changed 6 months ago by nero152 (Glen Roberts)

That worked. Thanks! UHD installed.

comment:12 Changed 6 months ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

Great! You're welcome & thanks for reporting back!

Note: See TracTickets for help on using tickets.