Opened 4 weeks ago

Last modified 4 weeks ago

#60416 assigned defect

freecad @0.18.4_1 build fails High Sierra 10.13.6 on Configuring freecad

Reported by: abiggerdogg Owned by: mbrethen
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: highsierra Cc: Schamschula (Marius Schamschula)
Port: freecad

Description (last modified by Schamschula (Marius Schamschula))

I've attached /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_cad_freecad/freecad/main.log

Michaels-MBP-2:workdir michaels$ sudo port install freecad
--->  Computing dependencies for freecad
--->  Fetching archive for freecad
--->  Attempting to fetch freecad-0.18.4_1+gcc9.darwin_17.x86_64.tbz2 from https://packages.macports.org/freecad
--->  Attempting to fetch freecad-0.18.4_1+gcc9.darwin_17.x86_64.tbz2 from http://aus.us.packages.macports.org/macports/packages/freecad
--->  Attempting to fetch freecad-0.18.4_1+gcc9.darwin_17.x86_64.tbz2 from https://ywg.ca.packages.macports.org/mirror/macports/packages/freecad
--->  Fetching distfiles for freecad
--->  Verifying checksums for freecad
--->  Extracting freecad
--->  Applying patches to freecad
--->  Configuring freecad
Error: Failed to configure freecad: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_cad_freecad/freecad/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port freecad failed

Attachments (1)

main.log (304.1 KB) - added by abiggerdogg 4 weeks ago.
main.log

Download all attachments as: .zip

Change History (5)

Changed 4 weeks ago by abiggerdogg

Attachment: main.log added

main.log

comment:1 Changed 4 weeks ago by Schamschula (Marius Schamschula)

Description: modified (diff)

comment:2 Changed 4 weeks ago by Schamschula (Marius Schamschula)

freecad doesn't enforce the boost variant. You have boost +python38 installed, but freecad needs boost +python27.

comment:3 Changed 4 weeks ago by abiggerdogg

Success:

sudo port install boost +python27

sudo port install freecad

Some questions:

1) I executed 'port info freecad' to see library dependencies and it showed:

Library Dependencies: qt4-mac, boost, Coin-framework, eigen3, freetype,

opencascade, py27-backports-functools_lru_cache, py27-matplotlib, py27-pivy, py27-pyside, py27-pyside-tools, py27-shiboken, SoQt, swig, swig-python, xercesc3, zlib, libgcc

Is there a way I could have determined that freecad requires the +python27 variant myself ?

2) I also downloaded a FreeCAD version 0.18 binary from the FreeCAD website, and it uses an embedded Python 3.6.7 interpreter. Installed by MacPort it uses an embedded Python 2.7.18 interpreter. Is there anyway I can get MacPorts to install a version/variant that uses a Python 3 interpreter ?

Last edited 4 weeks ago by abiggerdogg (previous) (diff)

comment:4 Changed 4 weeks ago by Schamschula (Marius Schamschula)

1) port info is the best way to find out the top level dependencies. port rdeps with give a hierarchical list.

2) Unfortunately, I have tried several times to make headway converting freecad to python 3.x, and for that matter to QT5, but with little success. I just have not had the time to devote to it.

Note: See TracTickets for help on using tickets.