Opened 12 days ago

Closed 7 days ago

#60731 closed defect (worksforme)

p5.30-mozilla-ca: Checksum mismatch

Reported by: jason-johnson (Jason) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.2
Keywords: Cc:
Port: p5-mozilla-ca

Description

When trying to install Git on Mac OSX Catalina 10.15.5 I get the following error:

--->  Fetching archive for p5.30-mozilla-ca
--->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from https://packages.macports.org/p5.30-mozilla-ca
--->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from http://lil.fr.packages.macports.org/p5.30-mozilla-ca
--->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from http://nue.de.packages.macports.org/p5.30-mozilla-ca
--->  Verifying checksums for p5.30-mozilla-ca
Error: Checksum (rmd160) mismatch for Mozilla-CA-20200520.tar.gz
Error: Checksum (sha256) mismatch for Mozilla-CA-20200520.tar.gz
Error: Checksum (size) mismatch for Mozilla-CA-20200520.tar.gz
Error: Failed to checksum p5.30-mozilla-ca: Unable to verify file checksums
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_perl_p5-mozilla-ca/p5.30-mozilla-ca/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port git failed

When checking the logs I see:

:debug:archivefetch chowned /opt/local/var/macports/incoming to macports
:debug:archivefetch euid/egid changed to: 504/501
:info:archivefetch --->  p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 doesn't seem to exist in /opt/local/var/macports/incoming/verified
:msg:archivefetch --->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from https://packages.macports.org/p5.30-mozilla-ca
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 
:msg:archivefetch --->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from http://lil.fr.packages.macports.org/p5.30-mozilla-ca
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found
:msg:archivefetch --->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from http://nue.de.packages.macports.org/p5.30-mozilla-ca
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 Not Found

I went to the sites shown there and indeed the file listed is not present.

Attachments (1)

main.log (47.9 KB) - added by jason-johnson (Jason) 11 days ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 days ago by jason-johnson (Jason)

I get the same problem with p5.28-mozilla-ca also.

comment:2 Changed 12 days ago by mf2k (Frank Schima)

Port: p5-mozilla-ca added; p5.30-mozilla-ca removed
Summary: Unable to install Git - p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 does not existp5.30-mozilla-ca: Checksum error

comment:3 Changed 12 days ago by mf2k (Frank Schima)

The error is a checksum error. It verifies for me so it appears to be an issue with the nue.de.packages.macports.org mirror.

comment:4 Changed 11 days ago by jason-johnson (Jason)

I think the reason the checksum is failing is because the files are not there so it's checksumming an empty file or something. I went to the URLs in the log and there were files there but none with 20200520 in the name.

comment:5 Changed 11 days ago by jason-johnson (Jason)

Summary: p5.30-mozilla-ca: Checksum errorp5.30-mozilla-ca: Missing files

Changing the title because this does not look like a checksum error to me. Checksum is just a symptom of the files being missing.

Last edited 11 days ago by jason-johnson (Jason) (previous) (diff)

comment:6 Changed 11 days ago by ryandesign (Ryan Schmidt)

Summary: p5.30-mozilla-ca: Missing filesp5.30-mozilla-ca: Checksum mismatch

The fact that the packages are not there has nothing to do with the fact that you're not able to verify the checksums of the distfile.

The packages are not there because we are not allowed to distribute them:

"p5.30-mozilla-ca" is not distributable because its license "mpl" conflicts with license "GPL-3+" of dependency "gdbm"

As for the distfile, all we know is the checksum didn't match on your system. I tried it on my system and I am unable to reproduce the problem. You didn't attach a main.log file and your transcript doesn't show what server the distfile was downloaded from. (It shows what servers it attempted to download the nonexistent packages from, which is irrelevant.)

Please follow the instructions at wiki:FAQ#checksums. Let us know what you find out.

comment:7 Changed 11 days ago by jason-johnson (Jason)

It very clearly shows in the error messages I've shown above from the console:

Fetching archive for p5.30-mozilla-ca
--->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from https://packages.macports.org/p5.30-mozilla-ca

etc.

Afterwards (from the log):

:msg:archivefetch --->  Attempting to fetch p5.30-mozilla-ca-20200520_0.darwin_19.noarch.tbz2 from https://packages.macports.org/p5.30-mozilla-ca
:debug:archivefetch Fetching archive failed: The requested URL returned error: 404 

etc. And now back to the error from the output:

Error: Checksum (rmd160) mismatch for Mozilla-CA-20200520.tar.gz

etc. The checksum doesn't match what's in the distfile because the distfile expects there to be a file with data in it, not an empty or non-existent file.

If you go to e.g. http://packages.macports.org/p5.30-mozilla-ca/ you will see it does have packages, just none with 20200520 in the name. Here is the list I see:

[   ]	p5.30-mozilla-ca-20180117_0.darwin_10.noarch.tbz2	2019-10-11 19:17	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_10.noarch.tbz2.rmd160	2019-10-11 19:17	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_11.noarch.tbz2	2019-10-11 02:08	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_11.noarch.tbz2.rmd160	2019-10-11 02:08	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_12.noarch.tbz2	2019-10-11 17:46	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_12.noarch.tbz2.rmd160	2019-10-11 17:46	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_13.noarch.tbz2	2019-10-10 17:11	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_13.noarch.tbz2.rmd160	2019-10-10 17:11	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_14.noarch.tbz2	2019-10-10 17:33	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_14.noarch.tbz2.rmd160	2019-10-10 17:33	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_15.noarch.tbz2	2019-10-10 19:27	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_15.noarch.tbz2.rmd160	2019-10-10 19:27	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_16.noarch.tbz2	2019-10-10 19:32	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_16.noarch.tbz2.rmd160	2019-10-10 19:32	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_17.noarch.tbz2	2019-10-11 15:42	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_17.noarch.tbz2.rmd160	2019-10-11 15:42	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_18.noarch.tbz2	2019-10-10 19:42	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_18.noarch.tbz2.rmd160	2019-10-10 19:42	512
[   ]	p5.30-mozilla-ca-20180117_0.darwin_19.noarch.tbz2	2019-11-09 15:47	136K
[   ]	p5.30-mozilla-ca-20180117_0.darwin_19.noarch.tbz2.rmd160	2019-11-09 15:47	512

So it would appear you do in fact distribute p5.30-mozilla-ca, just not the version that was set in the latest change to this port. On Github the previous version was 20180117 which is correct.

I am attaching the main.log which these excerpts were taking from. This does not look like a checksum issue but rather checksum is the first place that detected the problem, which is that someone made a commit which broke the package.

Last edited 7 days ago by ryandesign (Ryan Schmidt) (previous) (diff)

Changed 11 days ago by jason-johnson (Jason)

Attachment: main.log added

comment:8 Changed 11 days ago by jason-johnson (Jason)

Ok, I see in the log file it does actually find the file at a place called http://mirror.truenetwork.ru. I see that this file has been downloaded.

Never mind. I did the clean of that port and reinstalled and now it's working. Probably firewall interference. Sorry for the trouble, please close the ticket.

comment:9 Changed 7 days ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Glad you got it working. I've filed #60756 for the fact that MacPorts output is confusing and doesn't make the distinction between fetching binary archives and building from source more clear.

Note: See TracTickets for help on using tickets.