Opened 15 years ago

Closed 14 years ago

#6098 closed defect (worksforme)

BUG: imap-2004g.tar.Z does not download in cclient install

Reported by: public@… Owned by: mij@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: yeled@…, cckramer@…, pguyot (Paul Guyot), markd@…
Port:

Description

It seems that there is some sort of minimal authentication for anon downloads on the washington.edu ftp server causing downloads of imap-2004g to fail. I was unable to download the file using wget as well, but downloading into /opt/local/var/db/dports/distfiles/imap-uw using Firefox worked.

Here's the log from my earlier failed attempt to install php:

sudo port install php5 +mysql4 Password: ---> Fetching cclient ---> Attempting to fetch imap-2004g.tar.Z from ftp://ftp.cac.washington.edu/imap/ ---> Attempting to fetch imap-2004g.tar.Z from ftp://ftp.cac.washington.edu/imap/old/ ---> Attempting to fetch imap-2004g.tar.Z from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch imap-2004g.tar.Z from http://distfiles-msn.opendarwin.org/ ---> Attempting to fetch imap-2004g.tar.Z from http://distfiles-bay13.opendarwin.org/ ---> Attempting to fetch imap-2004g.tar.Z from http://distfiles-od.opendarwin.org/ ---> Attempting to fetch imap-2004g.tar.Z from http://distfiles-msn.opendarwin.org/ ---> Attempting to fetch imap-2004g.tar.Z from http://distfiles-bay13.opendarwin.org/ Error: Target com.apple.fetch returned: fetch failed Error: The following dependencies failed to build: cclient curl freetype gettext jpeg libmcrypt libpng libxml2 libxslt mhash mysql4 tidy tiff Error: /opt/local/bin/port: Status 1 encountered during processing.

Attachments (1)

Portfile.diff (1.4 KB) - added by markd@… 14 years ago.
Patch for update to imap-2006a

Download all attachments as: .zip

Change History (13)

comment:1 Changed 15 years ago by yeled@…

works for me.

12:23 backspace:~/Documents/darwinports% sudo port install php5 +mysql4 ---> Fetching cclient ---> Attempting to fetch imap-2004g.tar.Z from ftp://ftp.cac.washington.edu/imap/ ---> Verifying checksum(s) for cclient ---> Extracting cclient ---> Configuring cclient ---> Building cclient with target osx EXTRACFLAGS=-fno-common

what's your network setup? perhaps you could experiment with an ftp client and try passive vs. non- passive connexions etc for us?

comment:2 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to mij@…
Summary: imap-2004g.tar.Z does not download in cclient installBUG: imap-2004g.tar.Z does not download in cclient install

comment:3 Changed 15 years ago by yeled@…

Cc: yeled@… added

comment:4 Changed 15 years ago by mij@…

Resolution: worksforme
Status: newclosed

comment:5 Changed 14 years ago by cckramer@…

Cc: cckramer@… added

I have exactly the same problem. I am behind the firewall and transparent squid proxy. Unable to find how to make fetch work in passove mode.Please help.

comment:6 Changed 14 years ago by cckramer@…

On a related note: ---> Attempting to fetch php-5.1.4.tar.bz2 from http://www.php.net/distributions/ ---> Verifying checksum(s) for php5 ---> Extracting php5 ---> Configuring php5 ---> Building php5 with target all ---> Staging php5 into destroot ---> Packaging tgz archive for php5 5.1.4_3+darwin_8+macosx ---> Installing php5 5.1.4_3+darwin_8+macosx

If this is your first install, you might want ---> Activating php5 5.1.4_3+darwin_8+macosx ---> Cleaning php5

It says "If this is your first install, you might want" and then nothing! Yes, this is my first install. I might do what ? Please tell me what I might do! This mystery is killing me!

comment:7 Changed 14 years ago by yeled@…

Resolution: worksforme
Status: closedreopened

some variant magic needs to be applied here.

reopening.

comment:8 Changed 14 years ago by charles.friedman@…

I can confirm the problem while trying to install cclient (sudo port install -v cclient).

Note also that the 2004g version is now missing from the first master site (ftp://ftp.cac.washington.edu/imap/). The version on there is 2006a.

However, 2004g still exists on the second master site (ftp://ftp.cac.washington.edu/imap/old/), and I was able to download it from there inside both Firefox and Camino, and then complete the installation using port.

System versions: Tiger 10.4.7, port 1.320, Camino 1.0.3, Firefox 1.5.0.7 (basically, latest of everything as of this writing -- 25 September 2006)

For what it's worth, I'm behind a hardware firewall, ftp/sftp ports are open outbound, and I've never had a problem with ftp transfers in port (or anywhere else) before. Not sure if port is using FTP in active or passive mode; it's using whatever the system defaults are.

comment:9 Changed 14 years ago by markd@…

Cc: pguyot@… markd@… added
Summary: BUG: imap-2004g.tar.Z does not download in cclient installUPDATE: cclient - imap-2004g missing - patch for imap-2006a
Type: defectenhancement

I've attached a patch for the new imap-2006a that fetches and builds. I'm not knowledgable about this port though, so someone should check it out. It builds as a dependecy for PHP5 now is all I can tell you.

That "If this is your first install, you might want" ui_msg has got to be removed. I went back in the archives and it has never said any more so it should be deleted since we don't know what the author was going to say. I'll do it if no one else does.

It fetches for me fine behind a firewall so I don't think the fetching problem (while the tarball existed) is a MacPorts issue.

Changed 14 years ago by markd@…

Attachment: Portfile.diff added

Patch for update to imap-2006a

comment:10 Changed 14 years ago by markd@…

Summary: UPDATE: cclient - imap-2004g missing - patch for imap-2006aBUG: imap-2004g.tar.Z does not download in cclient install
Type: enhancementdefect

Ok, I spoke too soon. PHP5 didn't like the cclient 2006a patch and refused to build. I hadn't read this bug yet that said 2004g was available on a secondary site. Installed cclient 2004g and now PHP5 built ok.

comment:11 Changed 14 years ago by pguyot (Paul Guyot)

The reason why PHP5 code doesn't compile with cclient 2006a is that a function (utf8_mime2text) now has an additional parameter. After a look at both source codes, the old call is equivalent to the new call with 0 for the additional parameter. The question is: shall we patch PHP5 to cope with the new c-client APIs?

Moreover, I think the update to 2006 is not a solution to the original problem, which is about fetching the distfile.

The master sites are:

ftp://ftp.cac.washington.edu/imap/ \
ftp://ftp.cac.washington.edu/imap/old/ \
opendarwin

This is because when they release a new version, they put the current version into old/. Indeed, imap-2004g.tar.Z is not in ftp://ftp.cac.washington.edu/imap/ but in ftp://ftp.cac.washington.edu/imap/old/. On my box, I can just fetch the old version properly and I think there is something wrong with the network configuration of the original poster.

[9:07]/<5>mail/cclient(187)> sudo port checksum
---> Fetching cclient
---> Attempting to fetch imap-2004g.tar.Z from ftp://ftp.cac.washington.edu/imap/
---> Attempting to fetch imap-2004g.tar.Z from ftp://ftp.cac.washington.edu/imap/old/
---> Verifying checksum(s) for cclient

So I would be tempted to just mark this bug "worksforme".

comment:12 Changed 14 years ago by markd@…

Resolution: worksforme
Status: reopenedclosed

I was mistaken and thought it wasn't on any of the master_sites because of a local problem. It does download 2004g from the secondary site. In light of the new things introduced with imap-2006a, I would think waiting to upgrade it until PHP is updated to handle it might be the best thing. I think this should be closed also so I'll do it.

Note: See TracTickets for help on using tickets.