Opened 15 years ago

Closed 15 years ago

Last modified 11 years ago

#6123 closed defect (fixed)

Gnome Themes didn't find gtk-engines-2 when building

Reported by: m.rick@… Owned by: gnome-darwinports@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: markd@…
Port: gnome-themes

Description (last modified by jmroot (Joshua Root))

aymeric$ sudo port install gnome-themes
--->  Configuring gnome-themes
Error: Target com.apple.configure returned: configure failure: shell
command "cd
"/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_gnome_gnome-themes/work/gnome-themes-2.12.0"
&& CPPFLAGS="-L/opt/local/lib -I/opt/local/include" ./configure
--prefix=/opt/local --enable-all-themes" returned error 1
Command output: checking for ranlib... ranlib
checking for strip... strip
checking if gcc static flag  works... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking for gcc option to produce PIC... -fno-common
checking if gcc PIC flag -fno-common works... yes
checking if gcc supports -c -o file.o... yes
checking whether the gcc linker (/usr/bin/ld) supports shared
libraries... yes
checking dynamic linker characteristics... darwin8.3.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... yes
configure: creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... no
checking whether the g++ linker (/usr/bin/ld) supports shared
libraries... yes
checking for g++ option to produce PIC... -fno-common
checking if g++ PIC flag -fno-common works... yes
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/bin/ld) supports shared
libraries... yes
checking dynamic linker characteristics... darwin8.3.0 dyld
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
appending configuration tag "F77" to libtool
checking for pkg-config... /opt/local/bin/pkg-config
checking for gtk+-2.0 >= 2.0.0   gdk-pixbuf-2.0 >= 2.0.0   gtk-engines-2
> >= 2.5.0 ... Package gtk-engines-2 was not found in the pkg-config
search path. Perhaps you should add the directory containing
`gtk-engines-2.pc' to the PKG_CONFIG_PATH environment variable No
package 'gtk-engines-2' found
configure: error: Library requirements (gtk+-2.0 >= 2.0.0
gdk-pixbuf-2.0 >= 2.0.0   gtk-engines-2 >= 2.5.0 ) not met; consider
adjusting the PKG_CONFIG_PATH environment variable if your libraries are
in a nonstandard prefix so pkg-config can find them.

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to gnome-darwinports@…

Assign to maintainer.

comment:2 Changed 15 years ago by markd@…

Cc: markd@… added
Resolution: fixed
Status: newclosed

The port was fixed but this bug never closed.

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Component: baseports
Description: modified (diff)
Port: gnome-themes added
Note: See TracTickets for help on using tickets.