#61544 closed defect (duplicate)

unable to install qt5-qtbase on Big Sur

Reported by: ajsharff Owned by:
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

I am working on a Mac recently updated to MacOS 11 Big Sur. I have successfully installed the latest version of MacPorts and have successfully installed many ports.

However, I am unable to install a number of packages, particularly qt5-qtbase. I get the following messages:

a) Warning: The macOS 11.0 SDK does not appear to be installed. Ports may not build correctly.

The MacOSX11.0SDK is present in /Library/Developer/CommandLineTools/SDKs

b) Warning: You can install it as part of the Xcode Command Line Tools package by running `xcode-select --install'.

Xcode-select --install comes back saying the CLT are installed

c) Sorry, "moc" cannot be run on this version of macOS. Qt requires macOS 11.0.0 or later, you have macOS 10.16.0.

This, I think is the kicker!!!!

What is the solution?

Change History (1)

comment:1 Changed 23 months ago by michaelld (Michael Dickens)

Resolution: duplicate
Status: newclosed

Duplicate of #61103

Let's take any discussion of Qt5 on macOS 11 to that ticket

Note: See TracTickets for help on using tickets.