Opened 2 months ago

Last modified 5 weeks ago

#61551 reopened defect

grass7 build failure

Reported by: marc-brouard Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: Veence (Vincent), dershow
Port: grass7

Description (last modified by marc-brouard)

Install of QGIS3 fails during the make of grass-7.8.4

:info:build Started compilation: Wed Nov 18 22:03:19 GMT 2020
:info:build --
:info:build Errors in:
:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gis_grass7/grass7/work/grass-7.8.4/vector/v.in.pdal
:info:build --
:info:build In case of errors please change into the directory with error and run 'make'.
:info:build If you get multiple errors, you need to deal with them in the order they
:info:build appear in the error log. If you get an error building a library, you will
:info:build also get errors from anything which uses the library.
:info:build --
:info:build Finished compilation: Wed Nov 18 22:03:44 GMT 2020
:info:build make: *** [default] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gis_grass7/grass7/work/grass-7.8.4'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gis_grass7/grass7/work/grass-7.8.4" && /usr/bin/make -j8 -w default 
:info:build Exit code: 2
:error:build Failed to build grass7: command execution failed
:debug:build Error code: CHILDSTATUS 93850 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_gis_grass7/grass7/main.log for details.

Attachments (1)

main.log.zip (338.4 KB) - added by marc-brouard 2 months ago.
log file (zipped as it is over 10mb)

Download all attachments as: .zip

Change History (13)

comment:1 Changed 2 months ago by marc-brouard

Description: modified (diff)

comment:2 Changed 2 months ago by jmroot (Joshua Root)

Keywords: qgis3 grass removed
Port: grass7 added
Summary: Install QGIS3 failsgrass7 build failure

Please attach the log file.

Changed 2 months ago by marc-brouard

Attachment: main.log.zip added

log file (zipped as it is over 10mb)

comment:3 Changed 2 months ago by nilason

According to the log file the cause of this issue is:

:info:build dyld: Library not loaded: /opt/local/lib/libgdal.27.dylib
:info:build   Referenced from: /opt/local/lib/libpdalcpp.10.dylib
:info:build   Reason: image not found
:info:build make[3]: *** [v.in.pdal.tmp.html] Error 1

which indicates PDAL is linked to a GDAL version which isn't present anymore. If I'm not mistaken libgdal.27.dylib is GDAL version 3.1.

If /opt/local/bin/gdal-config --version gives any other result than 3.1 (my guess it will give 3.2), you may try reinstall PDAL separately.

comment:4 Changed 8 weeks ago by marc-brouard

Thank you nilason,

This sorted my problem.

comment:5 in reply to:  4 Changed 7 weeks ago by nilason

Replying to marc-brouard:

Thank you nilason,

This sorted my problem.

I'm glad it worked out for you!

I believe this ticked may be closed. Not really grass7 port specific issue, rather dependency conflict.

comment:6 Changed 7 weeks ago by mf2k (Frank Schima)

Resolution: invalid
Status: newclosed

comment:7 Changed 7 weeks ago by jmroot (Joshua Root)

Cc: Veence added

Is this really invalid? Sounds like pdal might need a revision bump to rebuild with a newer gdal?

comment:8 Changed 7 weeks ago by mf2k (Frank Schima)

Resolution: invalid
Status: closedreopened

comment:9 Changed 7 weeks ago by marc-brouard

I am sorry I can not provide any more information. The mac I was installing on has just died due to problems with the power logic board. I don't think the pwoer issue is related to this install in anyway.

comment:10 Changed 5 weeks ago by nilason

comment:11 Changed 5 weeks ago by Veence (Vincent)

I have updated versions of a lot of ports running locally, I will commit them

comment:12 Changed 5 weeks ago by dershow

Cc: dershow added
Note: See TracTickets for help on using tickets.