Opened 3 months ago

Closed 3 months ago

#61669 closed defect (duplicate)

db46: error: implicit declaration of function 'getopt' is invalid in C99

Reported by: BluDread Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: bigsur catalina Cc:
Port: db46

Description (last modified by ryandesign (Ryan Schmidt))

--->  Fetching archive for db46
--->  Attempting to fetch db46-4.6.21_10.darwin_20.x86_64.tbz2 from https://lil.fr.packages.macports.org/db46
--->  Attempting to fetch db46-4.6.21_10.darwin_20.x86_64.tbz2 from https://packages.macports.org/db46
--->  Attempting to fetch db46-4.6.21_10.darwin_20.x86_64.tbz2 from https://mse.uk.packages.macports.org/db46
--->  Building db46
Error: Failed to build db46: command execution failed

Attachments (1)

main.log (9.5 KB) - added by BluDread 3 months ago.
Log

Download all attachments as: .zip

Change History (3)

comment:1 Changed 3 months ago by BluDread

Summary: Error: Processing of port Xastir failedError: Processing of port Xastir failed Big Sur

Changed 3 months ago by BluDread

Attachment: main.log added

Log

comment:2 Changed 3 months ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: bigsur catalina added; Failed to build db46 dependency removed
Port: db46 added; Xastir removed
Resolution: duplicate
Status: newclosed
Summary: Error: Processing of port Xastir failed Big Surdb46: error: implicit declaration of function 'getopt' is invalid in C99

Duplicate of #61656

Note: See TracTickets for help on using tickets.