Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#6174 closed defect (worksforme)

BUG: cannot launch pgAdmin3 version 1.4.1_0

Reported by: g3zi7y.wu72nfp@… Owned by: jyrki.wahlstedt@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

The installation of pgAdmin3 @1.4.1_0 was apparently successful, but I cannot start the programm. I doubleclicked the icon in the directory "/Applications/DarwinPorts/", but nothing happens.

In the file "console.log" I found the message:

dyld: /Applications/DarwinPorts/pgAdmin3.app/Contents/MacOS/pgAdmin3 can't open library: @executable_path/Contents/Frameworks/libcrypto.0.9.8.dylib (No such file or directory, errno = 2)

Here the directory listing of "Frameworks":

My-Computer:/Applications/DarwinPorts/pgAdmin3.app/Contents/Frameworks wu$ ls -l total 28120 -rwxr-xr-x 2 root admin 1306300 18 Dec 23:58 libSDL-1.2.0.dylib -rwxr-xr-x 2 root admin 1427560 18 Dec 23:58 libcrypto.0.9.8.dylib -rwxr-xr-x 2 root admin 334440 18 Dec 23:58 libexpat.0.dylib -rwxr-xr-x 2 root admin 1124264 18 Dec 23:58 libiconv.2.dylib -rwxr-xr-x 2 root admin 134968 18 Dec 23:58 libjpeg.62.dylib -rwxr-xr-x 2 root admin 191244 18 Dec 23:58 libpng.3.dylib -rwxr-xr-x 2 root admin 163496 18 Dec 23:58 libpq.4.dylib -rwxr-xr-x 2 root admin 427344 18 Dec 23:58 libreadline.5.0.dylib -rwxr-xr-x 2 root admin 326848 18 Dec 23:58 libssl.0.9.8.dylib -rwxr-xr-x 2 root admin 866800 18 Dec 23:58 libtiff.3.dylib -rwxr-xr-x 2 root admin 6536964 18 Dec 23:58 libwx_macu-2.6.0.dylib -rwxr-xr-x 2 root admin 458156 18 Dec 23:58 libwx_macu_ogl-2.6.0.dylib -rwxr-xr-x 2 root admin 1002972 18 Dec 23:58 libwx_macu_stc-2.6.0.dylib -rwxr-xr-x 2 root admin 81032 18 Dec 23:58 libz.1.dylib

The library "libcrypto.0.9.8.dylib" exists !

Prior to the installation of pgAdmin3-1.4.1 I had installed the version 1.4.0, successful too, but I CAN start the program !

Here are some additional informations:

My-Computer:~ wu$ uname -a Darwin My-Computer.local 7.9.0 Darwin Kernel Version 7.9.0: Wed Mar 30 20:11:17 PST 2005; root: xnu/xnu-517.12.7.obj~1/RELEASE_PPC Power Macintosh powerpc

My-Computer:~ wu$ port version Version: 1.200

My-Computer:~ wu$ port echo installed and active and \( name:postgresql8 or name:wxWidgets or name:openssl \) openssl @0.9.8a_0 postgresql8 @8.1.1_0 wxWidgets @2.6.1_0

I am a newcomer to PostgreSQL and very interested in this matter.

Change History (4)

comment:1 Changed 15 years ago by mww@…

Summary: cannot launch pgAdmin3 version 1.4.1_0BUG: cannot launch pgAdmin3 version 1.4.1_0

comment:2 Changed 15 years ago by jyrki.wahlstedt@…

Resolution: worksforme
Status: newclosed

Sorry, can't reproduce that in my system. Then, I am running 10.4.3 and you are running apparently 10.3.9. That could make a difference. Currently I don't have Panther to test on (and really don't know, whether I am able to have one). Are you able to upgrade to Tiger? BTW, openssl is currently @0.9.8_0 and wxWidgets @2.6.2_0.

comment:3 Changed 15 years ago by g3zi7y.wu72nfp@…

I found a remedy of my problem:

I can start pgAdmin3-1.4.1 on my computer with the terminal application: My-Computer:~ wu$ declare -x DYLD_LIBRARY_PATH="/Applications/DarwinPorts/pgAdmin3.app/ Contents/Frameworks" My-Computer:~ wu$ My-Computer:~ wu$ /Applications/DarwinPorts/pgAdmin3.app/Contents/MacOS/pgAdmin3 Tiger has to wait a little longer ...

comment:4 Changed 15 years ago by jyrki.wahlstedt@…

(In reply to comment #2)

I found a remedy of my problem:

I can start pgAdmin3-1.4.1 on my computer with the terminal application: My-Computer:~ wu$ declare -x DYLD_LIBRARY_PATH="/Applications/DarwinPorts/pgAdmin3.app/ Contents/Frameworks" My-Computer:~ wu$ My-Computer:~ wu$ /Applications/DarwinPorts/pgAdmin3.app/Contents/MacOS/pgAdmin3 Tiger has to wait a little longer ...

Well, one nice thing with Tiger is that pgAdmin3 does not copy the libraries anymore, as is shown in: jwa@bruckner:Current> otool -L /Applications/DarwinPorts/pgAdmin3.app/Contents/MacOS/ pgAdmin3 /Applications/DarwinPorts/pgAdmin3.app/Contents/MacOS/pgAdmin3:

/opt/local/lib/libssl.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8) /opt/local/lib/libcrypto.0.9.8.dylib (compatibility version 0.9.8, current version 0.9.8) /opt/local/lib/pgsql8/libpq.4.dylib (compatibility version 4.0.0, current version 4.1.0) /System/Library/Frameworks/QuickTime.framework/Versions/A/QuickTime (compatibility version

1.0.0, current version 6.0.0)

/System/Library/Frameworks/IOKit.framework/Versions/A/IOKit (compatibility version 1.0.0,

current version 275.0.0)

/System/Library/Frameworks/Carbon.framework/Versions/A/Carbon (compatibility version 2.0.0,

current version 128.0.0)

/System/Library/Frameworks/Cocoa.framework/Versions/A/Cocoa (compatibility version 1.0.0,

current version 11.0.0)

/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version 88.1.2) /opt/local/lib/libwx_macu-2.6.0.dylib (compatibility version 2.0.0, current version 2.0.0) /opt/local/lib/libwx_macu_stc-2.6.0.dylib (compatibility version 2.0.0, current version 2.0.0) /opt/local/lib/libwx_macu_ogl-2.6.0.dylib (compatibility version 2.0.0, current version 2.0.0) /usr/lib/libstdc++.6.dylib (compatibility version 7.0.0, current version 7.3.0) /usr/lib/libgcc_s.1.dylib (compatibility version 1.0.0, current version 1.0.0)

So, all libraries are outside the app (as they should be).

Note: See TracTickets for help on using tickets.