Opened 5 weeks ago

Closed 3 weeks ago

#61901 closed defect (duplicate)

poppler 20.12.1: Failed to build (macOS 11.1 Big Sur)

Reported by: nhchan Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: bigsur Cc:
Port: poppler

Description

While trying to install py38-spyder, one of the dependencies is poppler, which failed to build.

Here is the terminal output when I tried to install poppler directly.

$ sudo port clean poppler  
Password:
--->  Cleaning poppler
$ sudo port install poppler
--->  Computing dependencies for poppler
--->  Fetching archive for poppler
--->  Attempting to fetch poppler-20.12.1_0.darwin_20.x86_64.tbz2 from https://packages.macports.org/poppler
--->  Attempting to fetch poppler-20.12.1_0.darwin_20.x86_64.tbz2 from https://lil.fr.packages.macports.org/poppler
--->  Attempting to fetch poppler-20.12.1_0.darwin_20.x86_64.tbz2 from https://cph.dk.packages.macports.org/poppler
--->  Fetching distfiles for poppler
--->  Verifying checksums for poppler
--->  Extracting poppler
--->  Applying patches to poppler
--->  Configuring poppler
--->  Building poppler
Error: Failed to build poppler: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets to report a bug.
Error: Processing of port poppler failed

I am going to attach the main.log file with this ticket.

FYI,

$ xcodebuild -version 
Xcode 12.3
Build version 12C33

Thanks for your attention.

Attachments (1)

main.log (728.6 KB) - added by nhchan 5 weeks ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log

Download all attachments as: .zip

Change History (10)

Changed 5 weeks ago by nhchan

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/main.log

comment:1 Changed 5 weeks ago by mf2k (Frank Schima)

Port: py38-spyder removed

comment:2 Changed 5 weeks ago by michaelld (Michael Dickens)

Here's the error:

:info:build llvm-objdump: Unknown command line argument '-macho'.  Try: '/opt/local/libexec/llvm-11/bin/llvm-objdump --help'
:info:build llvm-objdump: Did you mean '-h'?
:info:build llvm-objdump: Unknown command line argument '-dylibs-used'.  Try: '/opt/local/libexec/llvm-11/bin/llvm-objdump --help'
:info:build llvm-objdump: Did you mean '--dylibs-used'?
:info:build llvm-objdump: Unknown command line argument '-non-verbose'.  Try: '/opt/local/libexec/llvm-11/bin/llvm-objdump --help'
:info:build llvm-objdump: Did you mean '--non-verbose'?
:info:build Traceback (most recent call last):
:info:build   File "/opt/local/bin/g-ir-scanner", line 99, in <module>
:info:build     sys.exit(scanner_main(sys.argv))
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/scannermain.py", line 579, in scanner_main
:info:build     shlibs = create_binary(transformer, options, args)
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/scannermain.py", line 419, in create_binary
:info:build     shlibs = resolve_shlibs(options, binary, options.libraries)
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/shlibs.py", line 183, in resolve_shlibs
:info:build     _resolve_non_libtool(options, binary, non_libtool))
:info:build   File "/opt/local/lib/gobject-introspection/giscanner/shlibs.py", line 103, in _resolve_non_libtool
:info:build     output = subprocess.check_output(args)
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/subprocess.py", line 411, in check_output
:info:build     return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
:info:build   File "/opt/local/Library/Frameworks/Python.framework/Versions/3.8/lib/python3.8/subprocess.py", line 512, in run
:info:build     raise CalledProcessError(retcode, process.args,
:info:build subprocess.CalledProcessError: Command '['otool', '-L', '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_poppler/poppler/work/build/glib/tmp-introspectruj9csh0/Poppler-0.18']' returned non-zero exit status 1.

Looks like this is related to the cctools install. When I use cctools @927.0.2_6+llvm11, I see this issue too. When I use cctools @927.0.2_6+llvm10 I don't have the issue -- poppler builds cleanly.

What does the following return: port installed cctools?

comment:3 Changed 5 weeks ago by nhchan

Interesting. Here is what port installed cctools returned for me:

$ port installed cctools
The following ports are currently installed:
  cctools @927.0.2_6+llvm11 (active)

Thank you!

comment:4 Changed 5 weeks ago by kencu (Ken)

we need to again make the cctools port always install the +xcode variant on all newer systems.

It used to do that, but it was changed back from doing that last year.

I'll set it up shortly. I had it done already, but thought I could improve it further.

comment:5 Changed 5 weeks ago by kencu (Ken)

for now, do this:

sudo port -f uninstall cctools
sudo port -v install cctools +xcode

comment:6 Changed 5 weeks ago by kencu (Ken)

there are a few other tickets around about this same issue, but with other ports, depending on what the user was trying to build when they ran into this cctools thing.

Last edited 5 weeks ago by kencu (Ken) (previous) (diff)

comment:7 Changed 5 weeks ago by michaelld (Michael Dickens)

Using cctools +xcode works for me... please make it so @kencu !

comment:8 Changed 5 weeks ago by nhchan

@kencu, following your instructions to replace cctools with cctools +xcode works for me too. Thank you!

comment:9 Changed 3 weeks ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #61967.

Note: See TracTickets for help on using tickets.