Opened 3 weeks ago

Closed 2 days ago

#62010 closed defect (duplicate)

mpich-gcc9 @3.3.2: undefined symbols

Reported by: MurrayDaw Owned by: eborisch (Eric A. Borisch)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: bigsur Cc:
Port: mpich-gcc9

Description

After going to Big Sur, I cleaned out all my ports and started fresh with MacPorts. Installed gcc9 and then wanted to get mopish so I tried mpich-gcc9 but that gave a build failure.

I'll include the log.

Please advise.

Attachments (2)

headofmain.log (210.8 KB) - added by MurrayDaw 3 weeks ago.
tailofmain.log (2.3 MB) - added by MurrayDaw 3 weeks ago.

Change History (7)

Changed 3 weeks ago by MurrayDaw

Attachment: headofmain.log added

Changed 3 weeks ago by MurrayDaw

Attachment: tailofmain.log added

comment:1 Changed 3 weeks ago by ryandesign (Ryan Schmidt)

Keywords: bigsur added
Owner: set to eborisch
Port: mpich-gcc9 added
Status: newassigned
Summary: Failed to build mpich-gcc9: command execution failedmpich-gcc9 @3.3.2: undefined symbols
Version: 2.6.4

It would be simpler if you attached the entire compressed main.log file.

In tailofmain.log I see undefined symbols and I see libtool, so this is undoubtedly the well-known libtool bug https://debbugs.gnu.org/cgi/bugreport.cgi?bug=44605 which needs to be fixed not only in libtool (which we've done) but also in every other port whose build system was built using libtool.

comment:2 Changed 2 weeks ago by MurrayDaw

Thank you for the quick response.

I read what you wrote and also followed the link you sent. I think you’re telling me to apply the patch to mpich-gcc10 and any other port that generates a similar error. I followed another link and found the file dynamic_lookup-11.patch that I think can be used for this but I’m unsure about how to do that. Or maybe that isn’t correct.

Can you send me to instructions on what the next step should be?

Also, if I don't get an error during build of some port does that mean this libtools problem does not affect that particular port?

comment:3 Changed 2 weeks ago by ryandesign (Ryan Schmidt)

The part of my comment explaining how to fix the problem was meant for the maintainer of this port, to whom the ticket is assigned.

If you don't get an error building some port, then yes, that port is not affected by this issue.

comment:4 Changed 2 weeks ago by eborisch (Eric A. Borisch)

I don't have a BigSur platform to test on; let me know if there is something that needs to be applied to the mpich port to resolve the issue.

comment:5 Changed 2 days ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #61909.

Note: See TracTickets for help on using tickets.