Opened 3 months ago

Closed 3 months ago

#62039 closed defect (duplicate)

OSXFUSE Build Failure, MacOS Big Sur

Reported by: forrie (Forrest) Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc:
Port: osxfuse

Description (last modified by jmroot (Joshua Root))

The current version of OSXFUSE fails to build on MacOS Big Sur.

Relevant portion of log:

:info:build BUILD_BUILD_DIRECTORY=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work
:info:build Search for Xcode
:info:build Xcode 12.3 found at path '/Applications/Xcode.app/Contents/Developer'
:info:build XCODE_12_3_PATH=/Applications/Xcode.app/Contents/Developer
:info:build XCODE_INSTALLED=([0]=12.3)
:info:build XCODE_SDK_11_1_XCODE=([0]=12.3)
:info:build XCODE_SDK_INSTALLED=([0]=11.1)
:info:build Done searching for Xcode
:info:build Source extension osxfuse
:info:build Assertion 'common_is_variable DEFAULT_SDK_11_1_ARCHITECURES' failed
:info:build at common_variable_clone (./build.d/lib/common.sh, line 501)
:info:build at common_variable_clone (./build.d/lib/common.sh, line 514)
:info:build at build_target_invoke (./build.sh, line 657)
:info:build at build_main (./build.sh, line 943)
:info:build at main (./build.sh, line 951)
:info:build Terminated: 15
:info:build Received signal: SIGTERM
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work/osxfuse-osxfuse-48bc246" && ./build.sh -t packagemanager -a build -v 5 --build-directory="/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/work" -- -a x86_64 --framework-prefix="/opt/local" --fsbundle-prefix="/opt/local" --library-prefix="/opt/local"
:info:build Killed by signal: 15
:error:build Failed to build osxfuse: command execution failed
:debug:build Error code: CHILDKILLED 4066 SIGTERM {software termination signal}
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_fuse_osxfuse/osxfuse/main.log for details.

Attachments (1)

logfile.txt (293.5 KB) - added by forrie (Forrest) 3 months ago.
Full logfile produced from the port build and failure.

Download all attachments as: .zip

Change History (4)

Changed 3 months ago by forrie (Forrest)

Attachment: logfile.txt added

Full logfile produced from the port build and failure.

comment:1 Changed 3 months ago by jmroot (Joshua Root)

Description: modified (diff)
Port: osxfuse added

comment:2 Changed 3 months ago by jmroot (Joshua Root)

Probably a duplicate of #59316?

comment:3 Changed 3 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.