#62135 closed defect (fixed)

py-pyside2: Could not resolve SDK --show-sdk-path for 'macosx'

Reported by: chrstphrchvz (Christopher Chavez) Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc: pmetzger (Perry E. Metzger)
Port: py-pyside2

Description

pyXX-pyside2 builds are failing on macOS 10.9-10.13 (10.14 unknown):

https://ports.macports.org/port/py27-pyside2/builds

https://ports.macports.org/port/py36-pyside2/builds

https://ports.macports.org/port/py37-pyside2/builds

https://ports.macports.org/port/py38-pyside2/builds

https://ports.macports.org/port/py39-pyside2/builds

running build
Project ERROR: Could not resolve SDK --show-sdk-path for 'macosx'
error: Failed to query for Qt's QMAKE_MACOSX_DEPLOYMENT_TARGET.
Traceback (most recent call last):
  File "setup.py", line 296, in <module>
    setup_runner.run_setup()
  File "/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_python_py-pyside2/py38-pyside2/work/pyside-setup-opensource-src-5.15.2/build_scripts/setup_runner.py", line 163, in run_setup
    raise RuntimeError(msg)
RuntimeError: 
setup.py invocation failed with exit code: 1.

I'm not aware whether this issue existed prior to the recent pyside2 5.15.2 update. There appears to have been similar errors for other Qt ports but I do not know how it would be addressed for this port, or if an existing attempt to address it is ineffective.

(I do not use py-pyside2 on the affected macOS versions.)

Change History (5)

comment:1 Changed 23 months ago by kencu (Ken)

might "use_xcode yes" if it's not already in there.

comment:2 Changed 22 months ago by jasonliu-- (Jason Liu)

(I do not use py-pyside2 on the affected macOS versions.)

However, I do (my Portfile development machine runs 10.11). PySide2 support was recently added for the GUI viewer in the USD port, and I am currently in the process of updating its Portfile to this new version.

Looking on the builders, it looks like the cause of the pyside2 failures are different depending on the version of macOS. For example, the build for macOS 10.11 is failing due to CMake errors:

CMake Error at CMakeLists.txt:23 (find_package):
  Could not find a configuration file for package "Qt5" that is compatible
  with requested version "5.12".

  The following configuration files were considered but not accepted:

    /opt/local/libexec/qt5/lib/cmake/Qt5/Qt5Config.cmake, version: 5.11.3
    /opt/local/lib/cmake/Qt5/Qt5Config.cmake, version: 5.11.3



-- Configuring incomplete, errors occurred!
See also "/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_python_py-pyside2/py38-pyside2/work/pyside-setup-opensource-src-5.15.2/pyside3_build/py3.8-qt5.11.3-64bit-release/shiboken2/CMakeFiles/CMakeOutput.log".
error: Error configuring shiboken2
Traceback (most recent call last):
  File "setup.py", line 296, in <module>
    setup_runner.run_setup()
  File "/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_python_py-pyside2/py38-pyside2/work/pyside-setup-opensource-src-5.15.2/build_scripts/setup_runner.py", line 163, in run_setup
    raise RuntimeError(msg)
RuntimeError: 
setup.py invocation failed with exit code: 1.

which seems to imply that there's an error determining which version of Qt5 should be used (possibly related to, or could be the same error as Chris pointed to above), or it could also imply that there's an error trying to build the shiboken2 dependency? On the other hand, the build for macOS 10.12 is apparently failing because the dependency qt511-qtwebengine is failing to install.

Also, one more thing: Is there some way for pyside2 to be used with pyside-tools? Looking at its Portfile, it looks like pyside-tools only depends on pyside. Perhaps there needs to be a new pyside2-tools package? If that's the case, then I can file a new, separate Trac ticket.

comment:3 Changed 22 months ago by kencu (Ken)

I think 10.11 caps out at qt 5.11 , so if this software requires qt5.12, you are Out Of Luck.

comment:4 Changed 22 months ago by chrstphrchvz (Christopher Chavez)

Indeed pyside2 (at least since 5.12.2) has required Qt 5.12. PR opened to reflect this in the port (leaving this port unavailable for older OSes rather than re-adding old versions).

Last edited 22 months ago by chrstphrchvz (Christopher Chavez) (previous) (diff)

comment:5 Changed 22 months ago by chrstphrchvz (Christopher Chavez)

Resolution: fixed
Status: assignedclosed

In 8925eed5988a05f169bbf7356f44d373bc96ee43/macports-ports (master):

py-pyside2: requires at least Qt 5.12

Closes: #62135

[skip ci]

Note: See TracTickets for help on using tickets.