Opened 10 months ago

Closed 10 months ago

Last modified 10 months ago

#62152 closed defect (duplicate)

processing of port pgplot failed: Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)

Reported by: sselgueta Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: pgplot

Description (last modified by reneeotten (Renee Otten))

Hello, I want to install pgplot using macports for mac osx Big Sur, and failed.

Error: Failed to build pgplot: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/main.log for details.

Checked the main.log file and got this:

:info:build make: *** [gidriv.o] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/build" && /usr/bin/make -w all cpg pgplot.html pgplot-routines.tex
:info:build Exit code: 2
:error:build Failed to build pgplot: command execution failed
:debug:build Error code: CHILDSTATUS 30306 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/main.log for details.
version:1
:debug:sysinfo macOS 11.0 (darwin/20.1.0) arch arm

and

info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
:info:build make: *** [gidriv.o] Error 1
:info:build make: Leaving directory `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/build'
:info:build Command failed:  cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/build" && /usr/bin/make -w all cpg pgplot.html pgplot-routines.tex
:info:build Exit code: 2
:error:build Failed to build pgplot: command execution failed
:debug:build Error code: CHILDSTATUS 31513 2
:debug:build Backtrace: command execution failed
:debug:build     while executing
:debug:build "system {*}$notty {*}$nice $fullcmdstring"
:debug:build     invoked from within
:debug:build "command_exec build"
:debug:build     (procedure "portbuild::build_main" line 8)
:debug:build     invoked from within
:debug:build "$procedure $targetname"
:error:build See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/main.log for details.

Attachments (1)

main.log (329.7 KB) - added by sselgueta 10 months ago.
main.log file obtained after failing the installation of pgplot

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 months ago by reneeotten (Renee Otten)

Description: modified (diff)
Owner: set to MarcusCalhoun-Lopez
Status: newassigned

comment:2 Changed 10 months ago by reneeotten (Renee Otten)

Port: pgplot added

please attach the complete main.log file here as attachment.

comment:3 Changed 10 months ago by reneeotten (Renee Otten)

Resolution: duplicate
Status: assignedclosed

duplicate of #61711

comment:4 Changed 10 months ago by reneeotten (Renee Otten)

Priority: HighNormal

Changed 10 months ago by sselgueta

Attachment: main.log added

main.log file obtained after failing the installation of pgplot

comment:5 Changed 10 months ago by kencu (Ken)

1066	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:574:72:
1067	:info:build   574 |          DO 100 K=0,4095
1068	:info:build       |                                                                        1
1069	:info:build Warning: Fortran 2018 deleted feature: Shared DO termination label 100 at (1)
1070	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:575:72:
1071	:info:build   575 |   100       CODE(K,M)=0
1072	:info:build       |                                                                        1
1073	:info:build Warning: Fortran 2018 deleted feature: DO termination statement which is not END DO or CONTINUE with label 100 at (1)
1074	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:619:72:
1075	:info:build   619 |          DO 330 K=0,4095
1076	:info:build       |                                                                        1
1077	:info:build Warning: Fortran 2018 deleted feature: Shared DO termination label 330 at (1)
1078	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:620:72:
1079	:info:build   620 |   330       CODE(K,M)=0
1080	:info:build       |                                                                        1
1081	:info:build Warning: Fortran 2018 deleted feature: DO termination statement which is not END DO or CONTINUE with label 330 at (1)
1082	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:248:72:
1083	:info:build   248 |      :     CALL GRGI03(1, 1, BX, BY, 0, BX, BY, %VAL(PIXMAP))
1084	:info:build       |                                                                        1
1085	:info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
1086	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:266:72:
1087	:info:build   266 |      :     CALL GRGI01(IX0, IY0, IX1, IY1, IC, BX, BY, %VAL(PIXMAP))
1088	:info:build       |                                                                        1
1089	:info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
1090	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:275:72:
1091	:info:build   275 |      :     CALL GRGI01(IX0, IY0, IX0, IY0, IC, BX, BY, %VAL(PIXMAP))
1092	:info:build       |                                                                        1
1093	:info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
1094	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:288:72:
1095	:info:build   288 |      :                  %VAL(WORK))
1096	:info:build       |                                                                        1
1097	:info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
1098	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:367:72:
1099	:info:build   367 |      :     CALL GRGI03(IX0, IY0, IX1, IY1, IC, BX, BY, %VAL(PIXMAP))
1100	:info:build       |                                                                        1
1101	:info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
1102	:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_graphics_pgplot/pgplot/work/pgplot/drivers/gidriv.f:378:72:
1103	:info:build   378 |       CALL GRGI04(NBUF, RBUF, BX, BY, %VAL(PIXMAP), MAXIDX)
1104	:info:build       |                                                                        1
1105	:info:build Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
1106	:info:build make: *** [gidriv.o] Error 1

comment:6 Changed 10 months ago by kencu (Ken)

Summary: processing of port pgplot failedprocessing of port pgplot failed: Error: Type mismatch in argument 'pixmap' at (1); passed INTEGER(8) to INTEGER(1)
Note: See TracTickets for help on using tickets.