#62232 closed defect (fixed)

octave-chrono: remove openjdk12 dependency

Reported by: chrstphrchvz (Christopher Chavez) Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: octave-chrono

Description

The octave-chrono port was recently added ([6a42a9eacb/macports-ports]) containing a dependency on openjdk12. Public updates for OpenJDK 12 already ended 2019-09. Can the octave-chrono port use a supported Java version instead, preferably an LTS Java version e.g. openjdk11?

Also, was there a reason to not use the java portgroup? It's very unusual to directly depend on a specific openjdk port.

(I do not personally use this port. I would like to propose removing ports for unsupported Java versions.)

Change History (1)

comment:1 Changed 10 months ago by Schamschula (Marius Schamschula)

Resolution: fixed
Status: assignedclosed

In c235af7fdbee4145082522eb3aafd8f4fe286eae/macports-ports (master):

octave-chrono: mark as obsolete

Closes: #62232

Note: See TracTickets for help on using tickets.