Opened 15 years ago

Closed 14 years ago

#6255 closed defect (wontfix)

BUG: cln won't build

Reported by: mighty_ernie@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: gwright@…, markd@…
Port:

Description

I have gcc40 installed, but when I try to install cln, I get this:

/bin/sh ../libtool --mode=compile g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I/opt/ local/include -L/opt/local/lib -I../include -I../include -I./base -c ./base/output/cl_prin_globals.cc

g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I/opt/local/include -L/opt/local/lib -I../

include -I../include -I./base -c ./base/output/cl_prin_globals.cc -fno-common -DPIC -o .libs/ cl_prin_globals.o ../include/cln/string.h: In member function 'const char* cln::cl_string::asciz() const': ../include/cln/string.h:17: error: 'char cln::cl_heap_string::data [1]' is private ../include/cln/string.h:44: error: within this context ../include/cln/string.h: In member function 'long unsigned int cln::cl_string::length() const': ../include/cln/string.h:16: error: 'long unsigned int cln::cl_heap_string::length' is private ../include/cln/string.h:49: error: within this context ../include/cln/string.h: In member function 'char cln::cl_string::operator[](long unsigned int) const': ../include/cln/string.h:17: error: 'char cln::cl_heap_string::data [1]' is private ../include/cln/string.h:55: error: within this context make[3]: * [cl_prin_globals.lo] Error 1 make[2]: * [base/output.target] Error 2 make[1]: * [base.target] Error 2 make: * [all] Error 2

Change History (10)

comment:1 Changed 15 years ago by gwright@…

Owner: changed from darwinports-bugs@… to gwright@…

What is your version of OS X, processor type (G3, G4 or G5) and what is the output of

gcc-dp-4.0 --version

?

That will help in tracking down you problem. Also, when did you last run

sudo port selfupdate

to update the ports files?

Thanks, Greg

comment:2 Changed 15 years ago by mighty_ernie@…

I'm running 10.3.9 on a G4

You're right, I needed to perform a selfupdate, so I did a sync, followed by a selfupdate then did a clean install of all my packages (was unnecessary, but I did it regardless). The old bug is gone, but I'm seeing a new one.

The gcc-dp-4.0 version is: gcc-dp-4.0 (GCC) 4.0.2

The error I'm seeing now is:

/bin/sh ../libtool --mode=compile g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./ base/random/cl_random_def.cc

g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/

lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./base/random/cl_random_def.cc -fno-common -DPIC -o .libs/cl_random_def.o /var/tmpccKIT1cT.s:70:FATAL:Symbol _cl_modulecl_random_defdtorend already defined. make[3]: * [cl_random_def.lo] Error 1 make[2]: * [base/random.target] Error 2 make[1]: * [base.target] Error 2 make: * [all] Error 2

comment:3 Changed 15 years ago by gwright@…

Thanks. I'll see what I can find. For reference, I've been able to build and run all tests successfully on OS X 10.4.3 with Apple's gcc 4.0.1. Perhaps I need to build with the system glibtool on 10.3.x. I will make a new portfile you can try in the next couple of days.

Greg

comment:4 Changed 15 years ago by gwright@…

Do you have an older vesion of cln anywhere on your system? cln has a known bug in its build system that you can't build a new version with an older version installed, you must uninstall the old version first.

-Greg

comment:5 Changed 15 years ago by mighty_ernie@…

Not presently, no. I did once upon a time, but I deleted it and rebooted before attempting to install via darwinports.

comment:6 Changed 15 years ago by gwright@…

Status: newassigned

comment:7 Changed 15 years ago by mww@…

Summary: cln won't buildBUG: cln won't build

comment:8 Changed 15 years ago by gwright@…

severity: majornormal

Changed severity to normal. Still can't reproduce on 10.4.x.

comment:9 Changed 15 years ago by markd@…

Cc: markd@… added

It seems to be a problem only on 10.3. I iinstalled it on 10.4.5 just fine. I get the same error on 10.3. GCC 4.03 was the one installed as a dependency prior to cln. I'm sure there were never any non-DP versions of cln on it.

make SUBDIR=base/random /bin/sh ../libtool --mode=compile g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./base/random/cl_UL_random.cc

g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./base/random/cl_UL_random.cc -fno-common -DPIC -o .libs/cl_UL_random.o g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./base/random/cl_UL_random.cc -o cl_UL_random.o >/dev/null 2>&1

/bin/sh ../libtool --mode=compile g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./base/random/cl_random_def.cc

g++-dp-4.0 -O2 -fno-exceptions -finline-limit=1000 -I../include -I/opt/local/include -L/opt/local/lib -I/opt/local/include -I../include -I../include -I./base -Ibase -c ./base/random/cl_random_def.cc -fno-common -DPIC -o .libs/cl_random_def.o

/var/tmpccFxCqfz.s:86:FATAL:Symbol _cl_modulecl_random_defdtorend already defined. make[3]: * [cl_random_def.lo] Error 1 make[2]: * [base/random.target] Error 2 make[1]: * [base.target] Error 2 make: * [all] Error 2 Error: Target com.apple.build returned: shell command "LDFLAGS="-lstdc++ -Wl,-read_only_relocs,warning -L/opt/local/lib" make all" returned error 2

comment:10 Changed 14 years ago by gwright@…

Resolution: wontfix
Status: assignedclosed

I'm closing this bug by changing the portfile to simply exit with a message when built on Panther. cln pushes the compiler very hard and I don't see the prospect of the developers providing a workaround.

-Greg

Note: See TracTickets for help on using tickets.