Opened 6 months ago

Closed 6 months ago

#62734 closed defect (fixed)

ttyd @1.4.2: error: no member named 'ws_ping_pong_interval' in 'struct lws_context_creation_info'

Reported by: prasantjalan (Prasant Jalan) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: catalina Cc:
Port: ttyd

Description (last modified by ryandesign (Ryan Schmidt))

Unable to install ttyd with macport 2.6.4. ttyd 1.4.2 fails to

Steps to reproduce the behavior:

  1. update macports to 2.6.4
  2. sudo port install ttyd

Environment:

  • OS: [e.g. macOS 10.15.5 Catalina]
  • MacBook Pro (Retina, 15-inch, Mid 2015)
  • Xcode 12.4

While installing it gives the following error

Error: Failed to build ttyd: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_ttyd/ttyd/main.log for details.
Error: rev-upgrade failed: Error rebuilding ttyd

From the log file:

:info:build /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_net_ttyd/ttyd/work/ttyd-1.4.2/src/server.c:399:10: error: no member named 'ws_ping_pong_interval' in 'struct lws_context_creation_info'

Attachments (1)

main.log (48.6 KB) - added by prasantjalan (Prasant Jalan) 6 months ago.
build log file

Download all attachments as: .zip

Change History (5)

Changed 6 months ago by prasantjalan (Prasant Jalan)

Attachment: main.log added

build log file

comment:1 Changed 6 months ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: catalina added; ttyd removed
Milestone: MacPorts Future
Port: ttyd added; 2.6.4 removed
Summary: Unable to install ttyd@1.4.2 with macports 2.6.4 (Catalina)ttyd @1.4.2: error: no member named 'ws_ping_pong_interval' in 'struct lws_context_creation_info'

Looks like the port is several versions behind. We could try updating it to a newer version.

$ port livecheck ttyd
ttyd seems to have been updated (port version: 1.4.2, new version: 1.6.3)

comment:2 Changed 6 months ago by ryandesign (Ryan Schmidt)

I think this bug was fixed in this commit which was part of ttyd 1.6.2.

comment:3 Changed 6 months ago by prasantjalan (Prasant Jalan)

Any way to quick fix this one? Is there a way to manually (update to 1.6.2) install the package ?

comment:4 Changed 6 months ago by ryandesign (Ryan Schmidt)

Owner: set to ryandesign
Resolution: fixed
Status: newclosed

In 157a266eadf9bf44f3d3bb9be3b3e4d88b6a0ff9/macports-ports (master):

ttyd: Update to 1.6.3

Closes: #62734

Note: See TracTickets for help on using tickets.