#63482 closed defect (duplicate)

ffmpeg @4.4_4 can't be build

Reported by: hellhovnd (Jean-Pierre Chauvel) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc: amagela (Anthony M. Agelastos), MaurizioLoreti, Blokkendoos (Johan), orbeckst (Oliver Beckstein), mascguy (Christopher Nielsen)
Port: ffmpeg

Description

Apparently there's some deprecated code that is spewing warnings galore and for some reason the library libavutil can't be linked.

Attachments (1)

main.log (8.7 MB) - added by hellhovnd (Jean-Pierre Chauvel) 17 months ago.

Change History (13)

Changed 17 months ago by hellhovnd (Jean-Pierre Chauvel)

Attachment: main.log added

comment:1 Changed 17 months ago by jmroot (Joshua Root)

Cc: jeremyhu added
Keywords: ffmpeg removed
Owner: set to dbevans
Port: ffmpeg added
Status: newassigned
Summary: ffmpeg 4.4_4 can't be buildffmpeg @4.4_4 can't be build

comment:2 Changed 17 months ago by JDLH (Jim DeLaHunt)

Possibly related: #63443 ffmpeg-4.4_3+gpl2: Build Failed .

comment:3 Changed 17 months ago by JDLH (Jim DeLaHunt)

Reading the attached main.log file, I observe:

  1. This log appears to contain logs of multiple builds. The final build starts on line 12669. (I thought MacPorts always deleted the old log when attempting to build, so there would only be one build in the log file.)
  1. The actual port and variant string appears to be ffmpeg @4.4_4+gpl2. This is similar to #63443.
  1. The specific error message refers to "Undefined symbols for architecture x86_64", of the form "_ff_butterflies_fixed_sse2". This is similar to #63443 also.

So, I suspect that this report is a duplicate of #63443.

Some interesting excerpts from the attached main.log are:

… [elided] …
:debug:clean Starting logging for ffmpeg @4.4_4+gpl2
:debug:sysinfo macOS 11.5.2 (darwin/20.6.0) arch i386
:debug:sysinfo MacPorts 2.7.1
:debug:sysinfo Xcode 12.5.1
:debug:sysinfo SDK 11
:debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 11.0
… [elided] …
:info:build Undefined symbols for architecture x86_64:
:info:build   "_ff_butterflies_fixed_sse2", referenced from:
:info:build       _ff_fixed_dsp_init_x86 in fixed_dsp_init.o
:info:build   "_ff_butterflies_float_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_cpu_cpuid", referenced from:
:info:build       _ff_get_cpu_flags_x86 in cpu.o
:info:build   "_ff_cpu_xgetbv", referenced from:
:info:build       _ff_get_cpu_flags_x86 in cpu.o
:info:build   "_ff_evaluate_lls_sse2", referenced from:
:info:build       _ff_init_lls_x86 in lls_init.o
:info:build   "_ff_image_copy_plane_uc_from_sse4", referenced from:
:info:build       _ff_image_copy_plane_uc_from_x86 in imgutils_init.o
:info:build   "_ff_pixelutils_sad_16x16_mmxext", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_16x16_sse2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_32x32_avx2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_32x32_sse2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_8x8_mmx", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_8x8_mmxext", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_a_16x16_sse2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_a_32x32_avx2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_a_32x32_sse2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_u_16x16_sse2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_u_32x32_avx2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_pixelutils_sad_u_32x32_sse2", referenced from:
:info:build       _ff_pixelutils_sad_init_x86 in pixelutils_init.o
:info:build   "_ff_scalarproduct_float_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_update_lls_avx", referenced from:
:info:build       _ff_init_lls_x86 in lls_init.o
:info:build   "_ff_update_lls_fma3", referenced from:
:info:build       _ff_init_lls_x86 in lls_init.o
:info:build   "_ff_update_lls_sse2", referenced from:
:info:build       _ff_init_lls_x86 in lls_init.o
:info:build   "_ff_vector_dmac_scalar_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_dmac_scalar_fma3", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_dmac_scalar_sse2", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_dmul_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_dmul_scalar_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_dmul_scalar_sse2", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_dmul_sse2", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmac_scalar_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmac_scalar_fma3", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmac_scalar_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_add_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_add_fma3", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_add_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_reverse_avx", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_reverse_avx2", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_reverse_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_scalar_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_window_3dnowext", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build   "_ff_vector_fmul_window_sse", referenced from:
:info:build       _ff_float_dsp_init_x86 in float_dsp_init.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)
:info:build gmake: *** [ffbuild/library.mak:103: libavutil/libavutil.56.dylib] Error 1
… [elided] …

comment:4 Changed 16 months ago by amagela (Anthony M. Agelastos)

Cc: amagela added

comment:5 Changed 16 months ago by MaurizioLoreti

Cc: MaurizioLoreti added

comment:6 Changed 16 months ago by Blokkendoos (Johan)

Cc: Blokkendoos added

comment:7 Changed 16 months ago by Blokkendoos (Johan)

Cc: Blokkendoos removed

comment:8 Changed 16 months ago by Blokkendoos (Johan)

Cc: Blokkendoos added

comment:9 Changed 16 months ago by orbeckst (Oliver Beckstein)

Cc: orbeckst added

comment:10 Changed 16 months ago by mascguy (Christopher Nielsen)

Cc: mascguy added

comment:11 Changed 16 months ago by mascguy (Christopher Nielsen)

Cc: jeremyhu removed
Owner: changed from dbevans to jeremyhu

comment:12 Changed 16 months ago by mascguy (Christopher Nielsen)

Resolution: duplicate
Status: assignedclosed

Duplicate of issue:63443

Note: See TracTickets for help on using tickets.