Opened 4 weeks ago

Last modified 4 weeks ago

#63513 assigned defect

xorg-server crashes on Big Sur 11.6

Reported by: TomDev234 Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc:
Port: xorg-server

Description

xorg-server is constantly crashing and restarting on Big Sur 11.6

Change History (4)

comment:1 Changed 4 weeks ago by jmroot (Joshua Root)

Cc: jeremyhu@… removed
Keywords: xorg-server removed
Owner: changed from jeremyhu@… to jeremyhu

Can you attach a crash log?

comment:2 Changed 4 weeks ago by kencu (Ken)

Not sure if you're on an M1 or Intel, but I am running xorg-server on BigSur 11.6 Intel and it does not crash for me here.

comment:3 Changed 4 weeks ago by TomDev234

Here is the system.log

Sep 21 21:19:47 Toms-Mac-Pro X11.bin[71280]: getattrlist failed for /System/Library/Extensions/AppleIntelKBLGraphicsGLDriver.bundle/Contents/MacOS/AppleIntelKBLGraphicsGLDriver: #2: No such file or directory
Sep 21 21:19:47 Toms-Mac-Pro X11.bin[71280]: getattrlist failed for /Library/GPUBundles/AMDRadeonX5000GLDriver.bundle/Contents/MacOS/ATIRadeonX5000SCLib.dylib: #2: No such file or directory
Sep 21 21:19:47 Toms-Mac-Pro X11.bin[71280]: getattrlist failed for /System/Library/Extensions/AMDRadeonX5000GLDriver.bundle/Contents/MacOS/ATIRadeonX5000SCLib.dylib: #2: No such file or directory
Sep 21 21:19:47 Toms-Mac-Pro X11.bin[71280]: getattrlist failed for /Library/GPUBundles/AMDRadeonX6000GLDriver.bundle/Contents/MacOS/ATIRadeonX6000SCLib.dylib: #2: No such file or directory
Sep 21 21:19:47 Toms-Mac-Pro X11.bin[71280]: getattrlist failed for /System/Library/Extensions/AMDRadeonX6000GLDriver.bundle/Contents/MacOS/ATIRadeonX6000SCLib.dylib: #2: No such file or directory
Sep 21 21:19:47 Toms-Mac-Pro X11.bin[71280]: getattrlist failed for /System/Library/Frameworks/OpenGL.framework/Resources//GLRendererFloat.bundle/GLRendererFloat: #2: No such file or directory
Sep 21 21:19:49 Toms-Mac-Pro com.apple.xpc.launchd[1] (org.macports.startx): Service only ran for 4 seconds. Pushing respawn out by 6 seconds.
Sep 21 21:19:56 Toms-Mac-Pro com.apple.xpc.launchd[1] (com.apple.wifi.WiFiAgent): Service only ran for 0 seconds. Pushing respawn out by 10 seconds.

comment:4 Changed 4 weeks ago by jeremyhu (Jeremy Huddleston Sequoia)

Those system logs re irrelevant. The only thing which is indicative of a problem is "Sep 21 21:19:49 Toms-Mac-Pro com.apple.xpc.launchd[1] (org.macports.startx): Service only ran for 4 seconds. Pushing respawn out by 6 seconds" which idicates that the service crashed, but it is not actionable. I'd need to see the actual crash log.

Note: See TracTickets for help on using tickets.