#63567 closed defect (fixed)

certbot execution failed

Reported by: ArtKoKo Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc:
Port: certbot py-acme

Description

Hi Schamschula,

Sorry, new bug with dns-lexicon when certbot execution, perhaps in conflict with py39-cryptography

An unexpected error occurred:
pkg_resources.ContextualVersionConflict: (cryptography 35.0.0 (/opt/local/Library/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages), Requirement.parse('cryptography<4,>=2'), {'dns-lexicon'})

Change History (11)

comment:1 Changed 16 months ago by Schamschula (Marius Schamschula)

Not unexpected.

It seems there was a major change to py-cryptography. As I no don't personally use dns-lexicon under macOS I don't see this error unless I get a report.

comment:2 Changed 16 months ago by Schamschula (Marius Schamschula)

I've committed a revision bump for py-dns-lexicon. Let me know if that works for you.

comment:3 Changed 16 months ago by ArtKoKo

Selfupdate / uninstall / install py39-dns-lexicon @3.7.0_0 Nothing is happening. How can I check if your revision is applied correctly ?

comment:4 Changed 16 months ago by Schamschula (Marius Schamschula)

It takes a couple of hours for the update to be available via port sync or port self update.

You can see that there revision has been updated in GitHub: https://github.com/macports/macports-ports/commit/8b6bbd1e2c5978389184dd38611896d298daabc1

comment:5 Changed 16 months ago by ArtKoKo

upgraded to py39-dns-lexicon @3.7.0_1 same bug...
Can I downgrade py-cryptography ?

Last edited 16 months ago by ArtKoKo (previous) (diff)

comment:6 Changed 16 months ago by Schamschula (Marius Schamschula)

Port: certbot py-acme added; py39-dns-lexicon removed

I just tried loading certbot: The problem is with certbot itself (or perhaps py-acme).

I'm going to check if there is any information upstream.

comment:7 Changed 16 months ago by Schamschula (Marius Schamschula)

P.S. I did rebuild both against the current version of py39-cryptography

comment:9 Changed 16 months ago by ArtKoKo

Well done Schamschula,

Clearly a version 35 report bug instead of 3.5 which breaks the build constraints...

Last edited 16 months ago by ArtKoKo (previous) (diff)

comment:10 Changed 16 months ago by Schamschula (Marius Schamschula)

Unfortunately, I just heard back form the forum: The issue is with dns-lexicon. I tried to patch the pyproject.toml file, but the issue persists.

I've opened an upstream issue with py-dns-lexicon https://github.com/AnalogJ/lexicon/issues/969

comment:11 Changed 16 months ago by Schamschula (Marius Schamschula)

Resolution: fixed
Status: assignedclosed

In 54bf4cfbd625156c2e9452b638dddc324c91b36f/macports-ports (master):

py-dns-lexicon: update to 3.8.0

Closes: #63567

Note: See TracTickets for help on using tickets.