Opened 16 months ago

Closed 8 months ago

#63712 closed defect (duplicate)

qt5 broken on Monterey

Reported by: jwhowarth Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc: josephsacco, Tatsh (Andrew Udvare), chrstphrchvz (Christopher Chavez)
Port: qt5

Description

The current qt5 fails building qt5-base on Monterey with the errors...

Creating qmake...
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
Failed to resolve SDK path for 'macosx12'
c -o main.o -arch x86_64 -fconstant-cfstrings -MMD     -g  -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/library -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/src/3rdparty/tinycbor/src -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators/unix -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators/win32 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators/mac -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include/QtCore -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include/QtCore/5.15.2 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include/QtCore/5.15.2/QtCore -I../src/corelib/global -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/mkspecs/macx-clang -DQT_VERSION_STR=\"5.15.2\" -DQT_VERSION_MAJOR=5 -DQT_VERSION_MINOR=15 -DQT_VERSION_PATCH=2 -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DPROEVALUATOR_FULL -DQT_NO_FOREACH /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/main.cpp
make: c: No such file or directory
make: [main.o] Error 1 (ignored)

Change History (6)

comment:1 Changed 16 months ago by josephsacco

Cc: josephsacco added

comment:2 Changed 15 months ago by Tatsh (Andrew Udvare)

Cc: Tatsh added

comment:3 Changed 14 months ago by Tatsh (Andrew Udvare)

It seems this particular issue is no longer relevant. I am using Qt 5 without issue on Monterey.

comment:4 in reply to:  description Changed 10 months ago by chrstphrchvz (Christopher Chavez)

Replying to jwhowarth:

c -o main.o -arch x86_64 -fconstant-cfstrings -MMD     -g  -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/library -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/src/3rdparty/tinycbor/src -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators/unix -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators/win32 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/generators/mac -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include/QtCore -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include/QtCore/5.15.2 -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/include/QtCore/5.15.2/QtCore -I../src/corelib/global -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/mkspecs/macx-clang -DQT_VERSION_STR=\"5.15.2\" -DQT_VERSION_MAJOR=5 -DQT_VERSION_MINOR=15 -DQT_VERSION_PATCH=2 -DQT_BUILD_QMAKE -DQT_BOOTSTRAPPED -DPROEVALUATOR_FULL -DQT_NO_FOREACH /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_aqua_qt5/qt5-qtbase/work/qtbase-everywhere-src-5.15.2/qmake/main.cpp
make: c: No such file or directory

I’m fairly certain this is a duplicate of ticket:63154#comment:2.

comment:5 Changed 10 months ago by chrstphrchvz (Christopher Chavez)

Cc: chrstphrchvz added

comment:6 Changed 8 months ago by neverpanic (Clemens Lang)

Resolution: duplicate
Status: newclosed

See #63154.

Note: See TracTickets for help on using tickets.