Opened 13 months ago

Last modified 13 months ago

#63770 assigned defect

speedtest-cli 2.1.3 - certificate verify failed error

Reported by: strafer Owned by: kurthindenburg (Kurt Hindenburg)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc:
Port: speedtest-cli

Description (last modified by strafer)

On my MacBook Air running mcOS Mojave, I did a fresh install of MacPorts and then installed speedtest-cli 2.1.3. I then tried to run it and it gave the following error:

Retrieving speedtest.net configuration...
Cannot retrieve speedtest configuration
ERROR: <urlopen error [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1129)>

However, installing and running speedtest-cli via Homebrew (on another system also running macOS Mojave) does not produce this error. It runs as expected.

How can I fix this so speedtest-cli will run? Or do I need to wait for an update?

Change History (2)

comment:1 Changed 13 months ago by strafer

Description: modified (diff)

comment:2 Changed 13 months ago by ryandesign (Ryan Schmidt)

Owner: set to kurthindenburg
Status: newassigned

Hmm, it works for me on High Sierra.

There was the recent Let's Encrypt certificate authority expiration debacle, which did affect Mojave and earlier, and for which there is no good solution. Maybe for some reason that is affecting you and not me in this case. If so, upgrading to Catalina or later is recommended if possible.

Note: See TracTickets for help on using tickets.