Opened 9 months ago

Closed 2 months ago

#64768 closed defect (fixed)

gobject-introspection 1.70.0_1 +universal fails to build on 10.13

Reported by: JohnFHall (John Hall) Owned by: mascguy (Christopher Nielsen)
Priority: Normal Milestone:
Component: ports Version: 2.7.1
Keywords: Cc: evanmiller (Evan Miller), cooljeanius (Eric Gallager)
Port: gobject-introspection

Description

:info:build [26/168] rm -f girepository/libgirepository-gthash.a && llvm-ar csrD girepository/libgirepository-gthash.a girepository/libgirepository-gthash.a.p/gthash.c.o
:info:build [27/168] rm -f girepository/cmph/libcmph.a && llvm-ar csrD girepository/cmph/libcmph.a girepository/cmph/libcmph.a.p/bdz.c.o girepository/cmph/libcmph.a.p/bdz_ph.c.o girepository/cmph/libcmph.a.p/bmz8.c.o girepository/cmph/libcmph.a.p/bmz.c.o girepository/cmph/libcmph.a.p/brz.c.o girepository/cmph/libcmph.a.p/buffer_entry.c.o girepository/cmph/libcmph.a.p/buffer_manager.c.o girepository/cmph/libcmph.a.p/chd.c.o girepository/cmph/libcmph.a.p/chd_ph.c.o girepository/cmph/libcmph.a.p/chm.c.o girepository/cmph/libcmph.a.p/cmph.c.o girepository/cmph/libcmph.a.p/cmph_structs.c.o girepository/cmph/libcmph.a.p/compressed_rank.c.o girepository/cmph/libcmph.a.p/compressed_seq.c.o girepository/cmph/libcmph.a.p/fch_buckets.c.o girepository/cmph/libcmph.a.p/fch.c.o girepository/cmph/libcmph.a.p/graph.c.o girepository/cmph/libcmph.a.p/hash.c.o girepository/cmph/libcmph.a.p/jenkins_hash.c.o girepository/cmph/libcmph.a.p/miller_rabin.c.o girepository/cmph/libcmph.a.p/select.c.o girepository/cmph/libcmph.a.p/vqueue.c.o girepository/cmph/libcmph.a.p/vstack.c.o
:info:build [28/168] /usr/bin/clang  -o girepository/cmph/cmph-bdz-test girepository/cmph/cmph-bdz-test.p/.._cmph-bdz-test.c.o -L/opt/local/lib -I/opt/local/include -Wl,-dead_strip_dylibs -Wl,-headerpad_max_install_names -Wl,-undefined,error -Wl,-headerpad_max_install_names -arch x86_64 -arch i386 -pipe -Os -arch x86_64 -arch i386 girepository/cmph/libcmph.a /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib /opt/local/lib/libgobject-2.0.dylib -lm
:info:build FAILED: girepository/cmph/cmph-bdz-test 
:info:build /usr/bin/clang  -o girepository/cmph/cmph-bdz-test girepository/cmph/cmph-bdz-test.p/.._cmph-bdz-test.c.o -L/opt/local/lib -I/opt/local/include -Wl,-dead_strip_dylibs -Wl,-headerpad_max_install_names -Wl,-undefined,error -Wl,-headerpad_max_install_names -arch x86_64 -arch i386 -pipe -Os -arch x86_64 -arch i386 girepository/cmph/libcmph.a /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libintl.dylib /opt/local/lib/libgobject-2.0.dylib -lm
:info:build ld: warning: ignoring file girepository/cmph/libcmph.a, file was built for archive which is not the architecture being linked (x86_64): girepository/cmph/libcmph.a
:info:build Undefined symbols for architecture x86_64:
:info:build   "_cmph_config_new", referenced from:
:info:build       _build in .._cmph-bdz-test.c.o
:info:build   "_cmph_config_set_algo", referenced from:
:info:build       _build in .._cmph-bdz-test.c.o
:info:build   "_cmph_destroy", referenced from:
:info:build       _test_search_packed in .._cmph-bdz-test.c.o
:info:build   "_cmph_io_vector_adapter", referenced from:
:info:build       _build in .._cmph-bdz-test.c.o
:info:build   "_cmph_new", referenced from:
:info:build       _build in .._cmph-bdz-test.c.o
:info:build   "_cmph_pack", referenced from:
:info:build       _test_search_packed in .._cmph-bdz-test.c.o
:info:build   "_cmph_packed_size", referenced from:
:info:build       _test_search_packed in .._cmph-bdz-test.c.o
:info:build   "_cmph_search", referenced from:
:info:build       _test_search in .._cmph-bdz-test.c.o
:info:build   "_cmph_search_packed", referenced from:
:info:build       _test_search_packed in .._cmph-bdz-test.c.o
:info:build   "_cmph_size", referenced from:
:info:build       _test_search in .._cmph-bdz-test.c.o
:info:build       _test_search_packed in .._cmph-bdz-test.c.o
:info:build       _build in .._cmph-bdz-test.c.o
:info:build ld: symbol(s) not found for architecture x86_64
:info:build clang: error: linker command failed with exit code 1 (use -v to see invocation)

Attachments (1)

main.log.gz (6.3 KB) - added by JohnFHall (John Hall) 9 months ago.

Download all attachments as: .zip

Change History (7)

Changed 9 months ago by JohnFHall (John Hall)

Attachment: main.log.gz added

comment:1 Changed 9 months ago by jmroot (Joshua Root)

Owner: set to mascguy

comment:2 Changed 9 months ago by mascguy (Christopher Nielsen)

Cc: evanmiller added

comment:3 Changed 2 months ago by cooljeanius (Eric Gallager)

Cc: cooljeanius added

comment:4 Changed 2 months ago by mascguy (Christopher Nielsen)

Are you seeing the same failure with the latest version (1.72.0)?

comment:5 in reply to:  4 ; Changed 2 months ago by JohnFHall (John Hall)

Works fine now for me. Please close ticket...

Replying to mascguy:

Are you seeing the same failure with the latest version (1.72.0)?

comment:6 in reply to:  5 Changed 2 months ago by mascguy (Christopher Nielsen)

Resolution: fixed
Status: assignedclosed

Replying to JohnFHall:

Works fine now for me. Please close ticket...

Great, glad the issue is resolved!

Note: See TracTickets for help on using tickets.