Opened 9 months ago

Closed 9 months ago

#65120 closed defect (duplicate)

failed to build boost176 on m1 mac with variants "+universal"

Reported by: water137780117 Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 2.7.2
Keywords: Cc: water137780117, mascguy (Christopher Nielsen)
Port: boost176

Description

boost176 cannot be built with variants +universal

sudo port install boost176 +universal
--->  Computing dependencies for boost176
--->  Fetching archive for boost176
--->  Attempting to fetch boost176-1.76.0_3+no_single+no_static+python310+universal.darwin_21.arm64-x86_64.tbz2 from https://pek.cn.packages.macports.org/macports/packages/boost176
--->  Attempting to fetch boost176-1.76.0_3+no_single+no_static+python310+universal.darwin_21.arm64-x86_64.tbz2 from https://kmq.jp.packages.macports.org/boost176
--->  Attempting to fetch boost176-1.76.0_3+no_single+no_static+python310+universal.darwin_21.arm64-x86_64.tbz2 from https://packages.macports.org/boost176
--->  Fetching distfiles for boost176
--->  Verifying checksums for boost176
--->  Extracting boost176
--->  Applying patches to boost176
--->  Configuring boost176
--->  Building boost176
Error: Failed to build boost176: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_mirrors.tuna.tsinghua.edu.cn_macports_release_devel_boost176/boost176/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets if you believe there is a bug.

Attachments (1)

main.log (83.6 KB) - added by water137780117 9 months ago.
log of building boost176

Download all attachments as: .zip

Change History (4)

Changed 9 months ago by water137780117

Attachment: main.log added

log of building boost176

comment:1 Changed 9 months ago by water137780117

Cc: water137780117 added

comment:2 Changed 9 months ago by ryandesign (Ryan Schmidt)

Cc: mascguy added
Owner: set to michaelld
Status: newassigned

The log says:

error: 64-bit PPC compilation is not supported when targeting OSX 10.6 or later

which is obviously silly since you're trying to build for arm64 and x86_64.

comment:3 Changed 9 months ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Duplicate of #64954.

Note: See TracTickets for help on using tickets.