Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#65347 closed defect (duplicate)

p5.28-wx: build failure

Reported by: jithingopakumar (Jithin Gopakumar) Owned by: mojca (Mojca Miklavec)
Priority: Normal Milestone:
Component: ports Version: 2.7.2
Keywords: Cc: mascguy (Christopher Nielsen)
Port: p5-wx

Description (last modified by mascguy (Christopher Nielsen))

--->  Attempting to fetch p5.28-wx-0.993.200_0.darwin_20.x86_64.tbz2 from https://packages.macports.org/p5.28-wx
--->  Attempting to fetch p5.28-wx-0.993.200_0.darwin_20.x86_64.tbz2 from https://cph.dk.packages.macports.org/p5.28-wx
--->  Attempting to fetch p5.28-wx-0.993.200_0.darwin_20.x86_64.tbz2 from https://mse.uk.packages.macports.org/p5.28-wx
--->  Building p5.28-wx
Error: Failed to build p5.28-wx: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_perl_p5-wx/p5.28-wx/main.log for details.
Error: Follow https://guide.macports.org/#project.tickets if you believe there is a bug.
Error: Processing of port demeter failed

Attachments (1)

main.log (412.8 KB) - added by jithingopakumar (Jithin Gopakumar) 4 months ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 4 months ago by jithingopakumar (Jithin Gopakumar)

Description: modified (diff)

comment:2 Changed 4 months ago by mascguy (Christopher Nielsen)

Owner: set to mojca
Port: p5-wx added
Priority: HighNormal
Status: newassigned
Version: 2.7.2

comment:3 Changed 4 months ago by mascguy (Christopher Nielsen)

Description: modified (diff)
Summary: Building error p5.28-wxp5.28-wx: build failure

Can you attach the main.log?

comment:4 Changed 4 months ago by jithingopakumar (Jithin Gopakumar)

Hi, im unable to locate it. Do you know how to find it ? I’m using a mac.

comment:5 in reply to:  4 Changed 4 months ago by mascguy (Christopher Nielsen)

Replying to jithingopakumar:

Hi, im unable to locate it. Do you know how to find it ? I’m using a mac.

The full path is provided in the error output:

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_perl_p5-wx/p5.28-wx/main.log

comment:6 Changed 4 months ago by mascguy (Christopher Nielsen)

Cc: mascguy added

comment:7 in reply to:  6 Changed 4 months ago by jithingopakumar (Jithin Gopakumar)

Replying to mascguy: Well that location is empty. i can't locate the main.log file.

comment:8 Changed 4 months ago by ryandesign (Ryan Schmidt)

Run sudo port clean p5.28-wx and then try again to regenerate the logfile.

comment:9 in reply to:  8 Changed 4 months ago by jithingopakumar (Jithin Gopakumar)

Replying to ryandesign:

Run sudo port clean p5.28-wx and then try again to regenerate the logfile.

Yes that worked. I have attached the file.

Changed 4 months ago by jithingopakumar (Jithin Gopakumar)

Attachment: main.log added

comment:10 Changed 4 months ago by jmroot (Joshua Root)

Keywords: demeter removed
Resolution: duplicate
Status: assignedclosed

Duplicate of #61588.

comment:11 Changed 4 months ago by jithingopakumar (Jithin Gopakumar)

I see, but i don't find a solution for this problem in that #61588

Note: See TracTickets for help on using tickets.