Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#65378 closed defect (fixed)

xonsh fails to installl

Reported by: bestlem Owned by: Schamschula (Marius Schamschula)
Priority: Normal Milestone:
Component: ports Version: 2.7.2
Keywords: Cc: Schamschula (Marius Schamschula), bestlem
Port: xonsh

Description (last modified by bestlem)

xonsh 0.12.5 does not install.

the error also occurs on the build bots. e.g. https://build.macports.org/builders/ports-12_arm64-builder/builds/55949/steps/install-port/logs/stdio

The error seems to be (on my machine)

:info:build Traceback (most recent call last):
:info:build   File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_shells_xonsh/xonsh/work/xonsh-xonsh-db51410/setup.py", line 14, in <module>
:info:build     from wheel.bdist_wheel import bdist_wheel
:info:build ModuleNotFoundError: No module named 'wheel'

I got xonsh to build by installing py310-wheel. So that is a required fix. xonsh +python39 needs a similar fix.

Change History (4)

comment:1 Changed 6 months ago by bestlem

Description: modified (diff)

comment:2 Changed 6 months ago by Schamschula (Marius Schamschula)

Thanks for reporting this!

Even though I normally test build in trace mode, I haven't run into this issue.

However, checking the build bots, I see this issue was introduced with the latest version of xonsh.

comment:3 Changed 6 months ago by Schamschula (Marius Schamschula)

Owner: set to Schamschula
Resolution: fixed
Status: newclosed

In 852c18dfff72f84789d6ef85f2e6c7bbad7d3000/macports-ports (master):

xonsh: add py-wheel dependency

Closes: #65378

comment:4 Changed 6 months ago by bestlem

Thanks for fixing.

FYI I think this change was caused by xonsh PR https://github.com/xonsh/xonsh/pull/4803

Note: See TracTickets for help on using tickets.