Opened 3 months ago

Last modified 8 hours ago

#65742 assigned defect

Gnuradio gui stuck

Reported by: adamgao1996 Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version:
Keywords: qtgui Cc: ra1nb0w
Port: gnuradio

Description

macos12 M1max

qt gui stuck, not updating

Done

Generating: '/Users/yixuan/Documents/GnuRadio/Test.py'

Executing: /opt/local/Library/Frameworks/Python.framework/Versions/3.10/bin/python3.10 -u /Users/yixuan/Documents/GnuRadio/Test.py

/Users/yixuan/Documents/GnuRadio/Test.py:162: DeprecationWarning: distutils Version classes are deprecated. Use packaging.version instead.

if StrictVersion("4.5.0") <= StrictVersion(Qt.qVersion()) < StrictVersion("5.0.0"):

/Users/yixuan/Documents/GnuRadio/Test.py:65: DeprecationWarning: distutils Version classes are deprecated. Use packaging.version instead.

if StrictVersion(Qt.qVersion()) < StrictVersion("5.0.0"):

[INFO] [UHD] Mac OS; Clang version 13.0.0 (clang-1300.0.29.30); Boost_107600; UHD_4.2.0.1-MacPorts-20220728-4.2.0.1-321295fb [INFO] [X300] X300 initialization sequence... [INFO] [X300] Maximum frame size: 1472 bytes. [INFO] [X300] Radio 1x clock: 200 MHz

Attachments (2)

Screen Shot 2022-08-30 at 12.57.36 PM.png (327.7 KB) - added by adamgao1996 3 months ago.
Screen Shot 2022-08-30 at 12.57.44 PM.png (299.3 KB) - added by adamgao1996 3 months ago.

Download all attachments as: .zip

Change History (9)

Changed 3 months ago by adamgao1996

Changed 3 months ago by adamgao1996

comment:1 Changed 3 months ago by jmroot (Joshua Root)

Cc: ra1nb0w added
Owner: set to michaelld
Status: newassigned

comment:2 Changed 3 months ago by mascguy (Christopher Nielsen)

Not sure if these are related, but also see: issue:65489

comment:3 Changed 3 months ago by ra1nb0w

We should upgrade to gnuradio 3.10 before doing more investigation. perhaps is already fixed.

comment:4 Changed 2 months ago by kesterlester

Seeing talk in this thread of upgrading to gnuradio 3.10:

I came here to request that the version of gnuradio supplied by macports be raised from 3.8.5.0_1 (which is, as I understand it what I can get at present) to at least 3.9.4. This is because I have the issue described here:

https://github.com/gnuradio/gnuradio/issues/5613

which has allegedly been fixed in 3.9.4.

Last edited 2 months ago by kesterlester (previous) (diff)

comment:5 Changed 8 weeks ago by ra1nb0w

@kesterlester you can try to install gnuradio 3.10 from https://github.com/ra1nb0w/macports-ports/tree/gnuradio-3.10 and check if it is fixed for you

comment:6 Changed 6 days ago by J-in-MN

@ ra1nb0w can you please provide some hints as to what it means to "install gnuradio 3.10 from ​https://github.com/ra1nb0w/macports-ports/tree/gnuradio-3.10"?

Is there some config file setting or command line options I have to use in my macports install?

Or do I have to delete my entire macports install and rebuild it from source using the https://github.com/ra1nb0w/macports-ports/releases/tag/v2.8.0-archive?

Or do I replace my /opt/local/var/macports/sources/rsync.macports.org/release/tarballs/ports directory with a git clone of https://github.com/ra1nb0w/macports-ports/tree/gnuradio-3.10 and then build gnuradio from source with "sudo port -sv install gnuradio"?

BTW, thank you for your efforts to keep the SDRangel port up to date. I am using that until we can get gnuradio 3.10.4 working on macOS 13 on Apple Silicon.

comment:7 Changed 8 hours ago by ra1nb0w

probably the easiest way is to pull the PR from github https://github.com/macports/macports-ports/pull/14942 into the main ports repository.

Essentially, clone https://github.com/macports/macports-ports.git somewhere.

Configure /opt/local/etc/macports/sources.conf with the directory that you have cloned file:///Users/[user]/sources/github/macports-ports [default]

Then checkout the PR git fetch origin pull/14942/head:gnuradio-3.10 and select that branch git checkout gnuradio-3.10

To maintain the repository up-to-date use pull/rebase git command.

Note: See TracTickets for help on using tickets.