#65748 closed defect (fixed)

jemalloc @5.3.0: constant expression evaluates to -12 which cannot be narrowed to type 'unsigned int'

Reported by: dsteck Owned by: kencu (Ken)
Priority: Normal Milestone:
Component: ports Version: 2.7.2
Keywords: monterey ventura Cc: tungyuanhsiao
Port: jemalloc

Description

Crashes during build; problem seems to be "constant expression evaluates to -12 which cannot be narrowed to type 'unsigned int' [-Wc++11-narrowing]".

Monterey/x86_64 port installs fine (installs precompiled binary).

macOS 12.5.1 (21G83); Xcode 13.4.1, Build version 13F100; MacPorts 2.7.2

Attachments (1)

main.log (291.8 KB) - added by dsteck 18 months ago.
main.log

Download all attachments as: .zip

Change History (7)

Changed 18 months ago by dsteck

Attachment: main.log added

main.log

comment:1 Changed 18 months ago by kencu (Ken)

basically a duplicate of 65671

exactly what machine are you building on?

comment:2 Changed 18 months ago by dsteck

Ah, sorry, missed the other ticket. I'll see if the patch there works.

This is building on a MacBook Pro (13-inch, M1, 2020) (MacBookPro17,1).

comment:4 Changed 15 months ago by ryandesign (Ryan Carsten Schmidt)

Cc: tungyuanhsiao added
Keywords: ventura added; arm64 removed
Summary: jemalloc fails to build for Monterey/arm64jemalloc @5.3.0: constant expression evaluates to -12 which cannot be narrowed to type 'unsigned int'

Has duplicate #66309 (on macOS Ventura on x86_64).

comment:5 in reply to:  4 Changed 15 months ago by jmroot (Joshua Root)

Replying to ryandesign:

Has duplicate #66309 (on macOS Ventura on x86_64).

That ticket said M1 Pro in the summary, though the log said platform i386. Might have been running in Rosetta 2 due to an x86_64 terminal program or something, which would be a similar situation to building universal.

comment:6 Changed 14 months ago by kencu (Ken)

Owner: set to kencu
Resolution: fixed
Status: newclosed

In b96e6fc66897b29c45391b8cf70dd191f9d78167/macports-ports (master):

jemalloc: fix universal build on arm64

if rosetta is installed the test for address bits fails
when running the x86_64 configure.

closes: #65671
closes: #65748

Note: See TracTickets for help on using tickets.