Opened 10 days ago

Last modified 4 days ago

#66272 new defect

llvm-10: if given arguments: "VERSION_LESS" "2.7" Unknown arguments specified

Reported by: Vahid999 Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.8.0
Keywords: ventura Cc:
Port: llvm-10

Description (last modified by ryandesign (Ryan Schmidt))

Hi,

I have updated MacPorts on Ventura and installed Xcode 14.1.

When installing grace, I get the following:

Configuring llvm-10
Error: Failed to configure llvm-10: consult /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_llvm-10/llvm-10/work/build/CMakeFiles/CMakeError.log
Error: Failed to configure llvm-10: configure failure: command execution failed
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_lang_llvm-10/llvm-10/main.log for details.
Error: rev-upgrade failed: Error rebuilding llvm-10

However, when Chris (https://lists.macports.org/pipermail/macports-users/2022-November/051623.html) asked me to run

sudo port clean grace
sudo port -d configure grace

based on the output (transcript) attached to the above thread, he believes that grace fails at configure.

Thank you,

Vahid

Attachments (2)

CMakeError.log (32.9 KB) - added by Vahid999 10 days ago.
main.log (82.1 KB) - added by Vahid999 10 days ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 10 days ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: ventura added; Ventura grace removed
Port: grace added

Please attach the log.

Changed 10 days ago by Vahid999

Attachment: CMakeError.log added

Changed 10 days ago by Vahid999

Attachment: main.log added

comment:2 Changed 10 days ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: llvm-10 added; grace removed
Summary: Grace fails to configurellvm-10: if given arguments: "VERSION_LESS" "2.7" Unknown arguments specified

Everything in this ticket indicates a problem configuring llvm-10. The llvm-10 port has no idea that grace was the port you tried to install, so this failure has nothing to do with grace.

The log says the problem configuring llvm-10 was:

:info:configure sh: /bin/ps: Operation not permitted
:info:configure sh: /bin/ps: Operation not permitted
:info:configure CMake Error at CMakeLists.txt:658 (if):
:info:configure   if given arguments:
:info:configure     "VERSION_LESS" "2.7"
:info:configure   Unknown arguments specified
:info:configure -- Configuring incomplete, errors occurred!

If you have other logs showing a problem with grace, file a separate ticket, however the grace log you attached to the aforementioned mailing list post did not show any error; it showed successful configuration of grace, so there's no bug there, based on that log.

comment:3 Changed 5 days ago by easye

c.f. #66265

comment:4 Changed 4 days ago by kencu (Ken)

like #66265, I suspect /usr/bin/python2.7 is not actually python 2.7 on Ventura, but a script prompting a python installation or similar.

512	:info:configure -- Found PythonInterp: /usr/bin/python2.7 
513	:info:configure CMake Error at CMakeLists.txt:658 (if):
514	:info:configure   if given arguments:
515	:info:configure     "VERSION_LESS" "2.7"
516	:info:configure   Unknown arguments specified

https://github.com/llvm/llvm-project/blob/ef32c611aa214dea855364efd7ba451ec5ec3f74/llvm/CMakeLists.txt#L658

Last edited 4 days ago by kencu (Ken) (previous) (diff)
Note: See TracTickets for help on using tickets.