Opened 2 months ago

#66372 new defect

qjackctl @0.6.2_0: audio input does not work on macOS 12

Reported by: bal-agates Owned by:
Priority: Normal Milestone:
Component: ports Version: 2.8.0
Keywords: monterey Cc:
Port: qjackctl

Description

Contrary to the port health status at macports.org I was successful at building qjackctl 0.6.2 for ARM64 on macOS 12.6 (Monterey). I had never used this application before but largely it seemed to work. The only problem I had was for a small test case routing one input to one output produced no audio output. I believe that is because macOS 12 is blocking audio input connections for this app. This version of QjackCtl does not trigger macOS to query the user to grant audio input (microphone) permission. Also in macOS > System Preferences > Security & Privacy QjackCtl does not appear in the Microphone list so one cannot manually grant the permissions.

One workaround I read on the internet seemed to confirmed this theory. From Terminal.app I used ffmpeg to record some input. This prompted me to grant Terminal.app permissions to use audio input. Then I ran qjackctl from the Terminal and my small test case worked as expected. The audio input showed up on the output. But launching qjackctl.app directly still has the problem.

I see there is a much newer version of the qjackctl source code. Not sure if that addresses this issue.

Reference: using jack @1.9.21_0, Xcode 14.1.

Change History (0)

Note: See TracTickets for help on using tickets.