#67072 closed defect (fixed)

cmake-bootstrap @3.9.6: Cannot find appropriate C compiler on this system.

Reported by: ryandesign (Ryan Carsten Schmidt) Owned by: kencu (Ken)
Priority: Normal Milestone:
Component: ports Version: 2.8.1
Keywords: arm64 ventura Cc: kencu (Ken)
Port: cmake-bootstrap

Description

https://build.macports.org/builders/ports-13_arm64-builder/builds/11767/steps/install-dependencies/logs/stdio

Executing:  cd "/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_devel_cmake-bootstrap/cmake-bootstrap/work/cmake-3.9.6-x86_64" && ./configure --prefix=/opt/local/libexec/cmake-bootstrap --docdir=share/doc/cmake --parallel=8 --no-system-libs --no-server 
DEBUG: system:  cd "/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_devel_cmake-bootstrap/cmake-bootstrap/work/cmake-3.9.6-x86_64" && ./configure --prefix=/opt/local/libexec/cmake-bootstrap --docdir=share/doc/cmake --parallel=8 --no-system-libs --no-server 
---------------------------------------------
CMake 3.9.6, Copyright 2000-2017 Kitware, Inc. and Contributors
---------------------------------------------
Error when bootstrapping CMake:
Cannot find appropriate C compiler on this system.
Please specify one using environment variable CC.
See cmake_bootstrap.log for compilers attempted.

---------------------------------------------
Log of errors: /opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_devel_cmake-bootstrap/cmake-bootstrap/work/cmake-3.9.6-x86_64/Bootstrap.cmk/cmake_bootstrap.log
---------------------------------------------
Command failed:  cd "/opt/local/var/macports/build/_opt_bblocal_var_buildworker_ports_build_ports_devel_cmake-bootstrap/cmake-bootstrap/work/cmake-3.9.6-x86_64" && ./configure --prefix=/opt/local/libexec/cmake-bootstrap --docdir=share/doc/cmake --parallel=8 --no-system-libs --no-server 
Exit code: 6

Change History (3)

comment:1 Changed 15 months ago by kencu (Ken)

This appears to be a universal build of cmake-bootstrap.

So far I can't reproduce this... so we'll see how things play out for a while.

comment:2 Changed 15 months ago by kencu (Ken)

On my arm Mac, builds through without any intervention.

% port -v installed cmake-bootstrap
The following ports are currently installed:
  cmake-bootstrap @3.9.6_0+universal (active) requested_variants='+universal' platform='darwin 22' archs='arm64 x86_64' date='2023-03-09T13:20:17-0800'

comment:3 Changed 12 months ago by kencu (Ken)

Owner: set to kencu
Resolution: fixed
Status: newclosed

In a4fda7b98703ff055b9dacb7e1dca58d5376d490/macports-ports (master):

cmake-bootstrap: disable universal variant

this port does not need to be universal, being a
build tool without libraries, and trying to build
it universal can cause errors

closes #66213
closes #67072

Note: See TracTickets for help on using tickets.