Opened 15 years ago

Closed 15 years ago

#7191 closed defect (fixed)

Eterm faults 'cause of libast

Reported by: r_bar@… Owned by: yves@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: olegb@…, r_bar@…, chefkww@…
Port:

Description

Host Name: G4.local Date/Time: 2006-02-11 13:39:21 +0100 OS Version: 10.3.9 (Build 7W98) Report Version: 2

Command: Eterm Path: /opt/local/bin/Eterm Version: ??? (???) PID: 508 Thread: Unknown

Link (dyld) error:

dyld: /opt/local/bin/Eterm Undefined symbols: _strnlen _strrev

... using DarwinPorts 'own' libast-0.7.tar.gz and 'sudo port -v install libast': [...] checking for strrev... yes checking for strnlen... yes [...]

I compiled libast (from http://www.eterm.org/download/libast-0.7.tar.gz) with './configure --prefix=/opt/local' and got: [...] checking for strrev... no checking for strnlen... no [...]

Eterm now is working just fine ...

Attachments (1)

output_libast_eterm.rtf (163.3 KB) - added by chefkww@… 15 years ago.
output for libast and Eterm thru DP 1.2 on iMac G5 OSX.3.9

Download all attachments as: .zip

Change History (9)

comment:1 Changed 15 years ago by r_bar@…

Cc: r_bar@… added

comment:2 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to yves@…

Assigning to maintainer.

comment:3 Changed 15 years ago by olegb@…

Cc: olegb@… added

I cannot reproduce this - Yves ?

comment:4 Changed 15 years ago by yves@…

Neither can I, and I don't remember anything has changed since 10.3

comment:5 Changed 15 years ago by chefkww@…

Cc: chefkww@… added

I receive the same problem after successfully installing Eterm. I am not a programmer but from what I can tell I think the problem is in the new - libast 0.7

trying to run Eterm - after install

$Eterm dyld: Eterm Undefined symbols: _strnlen _strrev Trace/BPT trap $

After uninstalling Eterm and libast and reinstalling successfully, but I looked for the values and I get the same.

(copied from below)

... using DarwinPorts 'own' libast-0.7.tar.gz and 'sudo port -v install libast': [...] checking for strrev... yes checking for strnlen... yes [...]

comment:6 Changed 15 years ago by yves@…

This is weird, because these symbols are present in libast but not defined, while Eterm works ok for me

that is why a complete build output of both could help, maybe

Changed 15 years ago by chefkww@…

Attachment: output_libast_eterm.rtf added

output for libast and Eterm thru DP 1.2 on iMac G5 OSX.3.9

comment:7 Changed 15 years ago by yves@…

Owner: changed from yves@… to yves@…

I kind of pinpointed the problem : strnlen and strrev are undefined symbols defined as extern in libast.h :

#if !(HAVE_STRNLEN) extern size_t strnlen(const char *, size_t); #endif

The compiler does not choke on them because of the "undefined suppress" flag

Eterm does not use directly any of these symbols, so I don't know how it should all fit at runtime.

Any hint, anyone ?

comment:8 Changed 15 years ago by yves@…

Resolution: fixed
Status: newclosed

undefined suppress messed up the configuration ! fixed in cvs

Note: See TracTickets for help on using tickets.