Opened 15 years ago

Closed 15 years ago

#7922 closed defect (wontfix)

BUG: qt3 @3.3.5_1 build incorrectly uses files from the existing installation when upgrading

Reported by: josh_root@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: ben@…, markd@…, takanori@…
Port:

Description

The linker complains of undefined symbols for libqpng.so. I'll attach the relevant output.

Attachments (1)

qt3.port.log (2.4 KB) - added by josh_root@… 15 years ago.
relevant portion of "port -v upgrade qt3" output

Download all attachments as: .zip

Change History (4)

Changed 15 years ago by josh_root@…

Attachment: qt3.port.log added

relevant portion of "port -v upgrade qt3" output

comment:1 Changed 15 years ago by takanori@…

Could you remove the old qt3 port before install?

sudo port deactivate qt3 sudo port clean qt3 sudo port -d install qt3

Please tell me the result.

comment:2 Changed 15 years ago by josh_root@…

Summary: BUG: qt3 @3.3.5_1 fails to buildBUG: qt3 @3.3.5_1 build incorrectly uses files from the existing installation when upgrading

That worked. Summary changed.

comment:3 Changed 15 years ago by markd@…

Cc: markd@… added
Resolution: wontfix
Status: newclosed

Closing this. Some ports do require uninstalling manually under certain conditions. And right or wrong few resources, if any, are applied to fix these cases since usually the issues go beyond packaging.

Note: See TracTickets for help on using tickets.