Opened 14 years ago

Closed 14 years ago

#8010 closed enhancement (fixed)

Version of sane-backend is outdated

Reported by: Matthias.Wiesmann@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 1.0
Keywords: Cc: hama@…, takanori@…
Port:

Description

The port-file for sane-backend installs version 1.0.15, but the latest version is 1.0.17, which includes many bug fixes for Mac OS X.

This corrected port file seems to work

# $Id: Portfile,v 1.2 2005/01/06 23:37:19 toby Exp $

PortSystem 1.0 name sane-backends version 1.0.17 categories graphics maintainers hamahamazone.de description Backends for scanner access homepage http://www.sane-project.org/ platforms darwin

long_description These are the backends for the Scanner Access Now Easy \

project. They allow you to access various scanners either \ locally or remote using saned.

master_sites ftp://ftp.sane-project.org/pub/sane/${distname}/

checksums md5 b51c10da8a81a04e1bae88c9e6556df2

depends_lib lib:libjpeg:jpeg

configure.env LDFLAGS="-L${prefix}/lib" \

CPPFLAGS="-I${prefix}/include -no-cpp-precomp"

configure.args --mandir=${prefix}/share/man --without-gphoto2 \

--disable-local-backends

default_variants +local-backends

variant local-backends { depends_lib-append lib:libusb:libusb

configure.args-delete --disable-local-backends }

variant pnm-backend { configure.args-append --enable-pnm-backend }

Change History (2)

comment:1 Changed 14 years ago by takanori@…

Cc: takanori@… added

committed. thanks. (this bug can be closed.)

comment:2 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.