Opened 15 years ago

Closed 15 years ago

Last modified 5 years ago

#8155 closed defect (fixed)

uninstall should properly report versions when needed

Reported by: ray@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.2
Keywords: Cc:
Port:

Description (last modified by ryandesign (Ryan Schmidt))

I tried the following:

sh-2.05b# port uninstall perl5.8 5.8.7_0
--->  The following versons of perl5.8 are currently installed:
--->    perl5.8 5.8.7_0 (active)
--->    perl5.8 5.8.8_0+darwin_8
Error: /opt/local/bin/port: port uninstall failed: Registry error: Please
specify the full version as recorded in the port registry.
sh-2.05b# port uninstall perl5.8 5.8.8_0+darwin_8
--->  The following versons of perl5.8 are currently installed:
--->    perl5.8 5.8.7_0 (active)
--->    perl5.8 5.8.8_0+darwin_8
Error: /opt/local/bin/port: port uninstall failed: Registry error: Please
specify the full version as recorded in the port registry.
sh-2.05b# 

It did not occur to me to use the syntax for versions that one sees in the "port installed" output.

This should have said:

sh-2.05b# port uninstall perl5.8
--->  The following versons of perl5.8 are currently installed:
--->    perl5.8 @5.8.7_0 (active)
--->    perl5.8 @5.8.8_0+darwin_8
Error: /opt/local/bin/port: port uninstall failed: Registry error: Please specify the full version as recorded in the port registry.
sh-2.05b#

Then it would have been clear what was needed.

Change History (3)

comment:1 Changed 15 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

It looks like this has already been fixed in CVS.

comment:2 Changed 15 years ago by jberry@…

1/22/06 commit by jmpp.

comment:3 Changed 5 years ago by ryandesign (Ryan Schmidt)

Component: deprecatedbase
Description: modified (diff)
Note: See TracTickets for help on using tickets.