Opened 15 years ago

Closed 14 years ago

#8256 closed defect (worksforme)

GTK2 /opt/local/bin/gdk-pixbuf-csource cannot handle PNG files

Reported by: darwinports-geb0@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

The problem occurs when I build the libgnomeui library, which is required for any gnome port.

This is what I got:

/opt/local/bin/gdk-pixbuf-csource --raw --build-list $var > pixbufs-tmp && \ cat ./copyright.txt pixbufs-tmp > gnome-stock-pixbufs.h

failed to load "./stock_attach.png": Couldn't recognize the image file format for file './stock_attach.png'

As I searched out, gdk-pixbug-csource is part of the GTK distribution, and it uses "loaders". The loaders seem to be correctly installed to the /opt/local/lib/gtk-2.0/2.4.0/loaders , but the gdk-pixbuf.loaders file does not contain any entry.

I use MacOSX 10.4.6.

dluxpb:~ dlux$ port list installed Xft2 @2.1.7 x11/Xft2 aalib @1.4rc5 graphics/aalib apache2 @2.2.0 www/apache2 apg @2.2.3 security/apg apr @1.2.6 devel/apr apr @1.2.6 devel/apr apr-util @1.2.6 devel/apr-util apr-util @1.2.6 devel/apr-util atk @1.11.4 devel/atk audiofile @0.2.6 audio/audiofile autoconf @2.59 devel/autoconf automake @1.9.6 devel/automake binutils @2.16.1 devel/binutils bison @2.1 devel/bison bzip2 @1.0.3 archivers/bzip2 cairo @1.0.4 graphics/cairo cairo @1.0.4 graphics/cairo convmv @1.09 sysutils/convmv cups-headers @1.1.15 devel/cups-headers db4 @4.3.29 databases/db4 db44 @4.4.20 databases/db44 docbook-xml-scrollkeeper @4.2 textproc/docbook-xml-scrollkeeper docbook-xsl @1.69.1 textproc/docbook-xsl esound @0.2.36 audio/esound expat @2.0.0 textproc/expat expat @2.0.0 textproc/expat fontconfig @2.3.2 graphics/fontconfig freetype @2.1.10 print/freetype gd2 @2.0.33 graphics/gd2 gettext @0.14.5 devel/gettext gimp-print @4.2.7 print/gimp-print glib1 @1.2.10 devel/glib1 glib1 @1.2.10 devel/glib1 glib2 @2.10.1 devel/glib2 glib2 @2.10.1 devel/glib2 glib2 @2.10.1 devel/glib2 gnome-doc-utils @0.5.3 gnome/gnome-doc-utils gnome-icon-theme @2.12.1 gnome/gnome-icon-theme gnome-mime-data @2.4.2 gnome/gnome-mime-data gnupg2 @1.9.20 mail/gnupg2 gnupg2 @1.9.20 mail/gnupg2 gtk1 @1.2.10 x11/gtk1 gtk2 @2.8.16 x11/gtk2 hicolor-icon-theme @0.5 gnome/hicolor-icon-theme id3lib @3.8.3 audio/id3lib id3tool @1.2 audio/id3tool id3v2 @0.1.11 audio/id3v2 intltool @0.34.2 textproc/intltool jpeg @6b graphics/jpeg lablgtk @1.2.7 x11/lablgtk libart_lgpl @2.3.17 graphics/libart_lgpl libassuan @0.6.10 devel/libassuan libbonobo @2.14.0 gnome/libbonobo libbonobo @2.14.0 gnome/libbonobo libgcrypt @1.2.2 devel/libgcrypt libgnomecups @0.2.2 gnome/libgnomecups libgnomeprint @2.12.1 gnome/libgnomeprint libgpg-error @1.1 devel/libgpg-error libiconv @1.10 textproc/libiconv libidl @0.8.6 devel/libidl libksba @0.9.12 devel/libksba libpixman @0.1.6 graphics/libpixman libpng @1.2.8 graphics/libpng libtool @1.5.20 devel/libtool libxml2 @2.6.22 textproc/libxml2 libxslt @1.1.15 textproc/libxslt md5deep @1.9.3 security/md5deep md5deep @1.9.3 security/md5deep mmencode @2.7 textproc/mmencode mod_fastcgi @2.4.2 www/mod_fastcgi neon @0.25.5 www/neon neon @0.25.5 www/neon ocaml @3.09.1 lang/ocaml ocaml @3.09.1 lang/ocaml openssl @0.9.8a devel/openssl orbit2 @2.14.0 devel/orbit2 orbit2 @2.14.0 devel/orbit2 p5-appconfig @1.56 perl/p5-appconfig p5-berkeleydb @0.26 perl/p5-berkeleydb p5-class-date @1.1.8 perl/p5-class-date p5-compress-zlib @1.41 perl/p5-compress-zlib p5-dbd-pg @1.45 perl/p5-dbd-pg p5-dbd-pg @1.45 perl/p5-dbd-pg p5-dbi @1.50 perl/p5-dbi p5-dbi @1.50 perl/p5-dbi p5-dtemplate @2.4 perl/p5-dtemplate p5-email-valid @0.15 perl/p5-email-valid p5-fastglob @1.3 perl/p5-fastglob p5-fcgi @0.67 perl/p5-fcgi p5-font-afm @1.19 perl/p5-font-afm p5-gd @2.32 perl/p5-gd p5-gd @2.32 perl/p5-gd p5-html-format @2.04 perl/p5-html-format p5-html-parser @3.51 perl/p5-html-parser p5-html-tagset @3.10 perl/p5-html-tagset p5-html-tree @3.18 perl/p5-html-tree p5-io-stringy @2.110 perl/p5-io-stringy p5-io-stringy @2.110 perl/p5-io-stringy p5-libwww-perl @5.805 perl/p5-libwww-perl p5-mac-applescript @0.04 perl/p5-mac-applescript p5-mac-applescript-glue @0.03 perl/p5-mac-applescript-glue p5-mailtools @1.74 perl/p5-mailtools p5-mime-base64 @3.05 perl/p5-mime-base64 p5-mime-lite @3.01 perl/p5-mime-lite p5-mime-tools @5.418 perl/p5-mime-tools p5-pod-escapes @1.04 perl/p5-pod-escapes p5-pod-simple @3.02 perl/p5-pod-simple p5-system-path @2 perl/p5-system-path p5-template-toolkit @2.14 perl/p5-template-toolkit p5-test-builder-tester @0.09 perl/p5-test-builder-tester p5-test-harness @2.46 perl/p5-test-harness p5-test-pod @1.16 perl/p5-test-pod p5-timedate @1.16 perl/p5-timedate p5-unicode-string @2.09 perl/p5-unicode-string p5-uri @1.35 perl/p5-uri p5-xml-parser @2.34 perl/p5-xml-parser pango @1.12.0 x11/pango pango @1.12.0 x11/pango pcre @6.6 devel/pcre pcre @6.6 devel/pcre perl5.8 @5.8.8 lang/perl5.8 perl5.8 @5.8.8 lang/perl5.8 pkgconfig @0.20 devel/pkgconfig popt @1.10.4 devel/popt postgresql8 @8.1.3 databases/postgresql8 postgresql8 @8.1.3 databases/postgresql8 pth @2.0.6 devel/pth putty @0.56 security/putty py-libxml2 @2.6.16 python/py-libxml2 python24 @2.4.2 lang/python24 readline @5.0.005 devel/readline render @0.9 x11/render scrollkeeper @0.3.14 textproc/scrollkeeper sleepnow @20040616 sysutils/sleepnow sleepnow @20040616 sysutils/sleepnow subversion @1.3.1 devel/subversion subversion @1.3.1 devel/subversion tiff @3.8.0 graphics/tiff watch @3.2.1 sysutils/watch wget @1.10.2 net/wget xrender @0.9.0 x11/xrender zlib @1.2.3 archivers/zlib

Change History (5)

comment:1 Changed 15 years ago by darwinports-geb0@…

Might be the duplicate of bug #8171.

comment:2 Changed 15 years ago by julian@…

A clean rebuild of libpng and gtk fixed this for me.

comment:3 Changed 15 years ago by darwinports-geb0@…

It have not solved for me.

Although I could rebuild the "/opt/local/etc/gtk-2.0/gdk-pixbuf.loaders" by manually running the "gdk-pixbuf-query-loaders" on the directory "/opt/local/lib/gtk-2.0/2.4.0/loaders".

comment:4 Changed 14 years ago by markd@…

Cc: markd@… added

Has this been resolved?

comment:5 Changed 14 years ago by markd@…

Resolution: worksforme
Status: newclosed

No feedback.

Note: See TracTickets for help on using tickets.