Opened 15 years ago

Closed 15 years ago

#9320 closed defect (fixed)

BUG: graphicsmagic-1.1.7

Reported by: marcus@… Owned by: mww@…
Priority: High Milestone:
Component: ports Version: 1.2
Keywords: Cc: jsiegel@…
Port:

Description

When installing graphicsmagic, I get this error:

sudo port install graphicsmagick Password: ---> Building GraphicsMagick with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_graphics_GraphicsMagick/work/GraphicsMagick-1.1.7" && make all" returned error 2 Command output: Making all in ltdl make[1]: Nothing to be done for `all'. Making all in config make[1]: Nothing to be done for `all'. Making all in coders if /bin/sh ../libtool --silent --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I../magick -I../magick -I.. -I.. -I/opt/local/include/freetype2 -I/opt/local/include/freetype2 -I/opt/local/include -I/opt/local/include/libxml2 -I/opt/local/include/freetype2 -I/opt/local/include -Wall -MT png.lo -MD -MP -MF ".deps/png.Tpo" -c -o png.lo png.c; \ then mv -f ".deps/png.Tpo" ".deps/png.Plo"; else rm -f ".deps/png.Tpo"; exit 1; fi png.c: In function 'ReadOnePNGImage': png.c:1712: warning: implicit declaration of function 'png_access_version' png.c:1721: error: 'png_ptr' undeclared (first use in this function) png.c:1721: error: (Each undeclared identifier is reported only once png.c:1721: error: for each function it appears in.) make[1]: * [png.lo] Error 1 make: * [all-recursive] Error 1

Error: /opt/local/bin/port: Status 1 encountered during processing.

FWIW, imagemagick installed ok.

Change History (3)

comment:1 Changed 15 years ago by mww@…

Owner: changed from darwinports-bugs@… to mww@…
severity: blockernormal

comment:2 Changed 15 years ago by mww@…

Cc: jsiegel@… added

* Bug 9489 has been marked as a duplicate of this bug. *

comment:3 Changed 15 years ago by mww@…

Resolution: fixed
Status: newclosed

o.k., I've added jsiegel@…'s patch - please re-open this bug if it will still not work despite the patch!

Note: See TracTickets for help on using tickets.