Opened 13 years ago

Closed 12 years ago

Last modified 10 years ago

#9338 closed defect (duplicate)

mzscheme build error (Intel)

Reported by: cabanaj13@… Owned by: kvv@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: DarwinPorts Cc:
Port:

Description

The following sequence is produced in response to ~root$ sudo port install mzscheme on Mac Intel:

---> Building mzscheme with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_lang_mzscheme/work/plt/src" && make all" returned error 2 Command output: make mz cd mzscheme; make make g-c cd gc; make ../libmzgc.a gcc -I./include -DNO_SIGNALS -I/opt/local/include -Wall -DOS_X -I/opt/local/include -fno-common -DNO_EXECUTE_PERMISSION -DSILENT -DNO_GETENV -DLARGE_CONFIG -DATOMIC_UNCOLLECTABLE -DINITIAL_MARK_STACK_SIZE=8192 -c ./alloc.c In file included from ./include/private/gc_priv.h:66,

from ./alloc.c:19:

./include/private/gcconfig.h:289: error: parse error before '--' token ./alloc.c: In function 'GC_expand_hp_inner':

./alloc.c:943: warning: suggest parentheses around && within

./alloc.c: In function 'GC_collect_or_expand':

./alloc.c:1009: warning: suggest parentheses around && within

make[4]: * [alloc.o] Error 1 make[3]: * [g-c] Error 2 make[2]: * [bin] Error 2 make[1]: * [mz] Error 2 make: * [all] Error 2

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (5)

comment:1 Changed 13 years ago by kevin@…

Component: darwinbuilddports
Keywords: DarwinPorts added; darwinbuild removed
product: darwinbuildDarwinPorts
Version: current1.2

comment:2 Changed 13 years ago by macports@…

This appears to be a duplicate of #9043

comment:3 Changed 12 years ago by pipping@…

Milestone: Port Bugs

comment:4 Changed 12 years ago by markd@…

Resolution: duplicate
Status: newclosed

Dpulicate of #8262.

comment:5 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.