Opened 14 years ago

Closed 14 years ago

#9416 closed enhancement (fixed)

update py-matplotlib port to version 0.87.4

Reported by: skymoo (Adam Mercer) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

The current py-matplotlib plot is quite an old version, this updates the port to version 0.87.3

Attachments (3)

Portfile.diff (824 bytes) - added by skymoo (Adam Mercer) 14 years ago.
patch to Portfile to build 0.87.3
patch-setupext.py.diff (843 bytes) - added by skymoo (Adam Mercer) 14 years ago.
updated patch to setupext.py for 0.87.4
Portfile.2.diff (824 bytes) - added by skymoo (Adam Mercer) 14 years ago.
patch to Portfile to build 0.87.4

Download all attachments as: .zip

Change History (11)

Changed 14 years ago by skymoo (Adam Mercer)

Attachment: Portfile.diff added

patch to Portfile to build 0.87.3

Changed 14 years ago by skymoo (Adam Mercer)

Attachment: patch-setupext.py.diff added

updated patch to setupext.py for 0.87.4

Changed 14 years ago by skymoo (Adam Mercer)

Attachment: Portfile.2.diff added

patch to Portfile to build 0.87.4

comment:1 Changed 14 years ago by skymoo (Adam Mercer)

attachments.isobsolete: 01

comment:2 Changed 14 years ago by skymoo (Adam Mercer)

attachments.description: updated patch to setupext.py for 0.87.3updated patch to setupext.py for 0.87.4

comment:3 Changed 14 years ago by skymoo (Adam Mercer)

Summary: update py-matplotlib port to version 0.87.3update py-matplotlib port to version 0.87.4

comment:4 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: fixed
Status: newclosed

Committed. Thanks!

comment:5 Changed 14 years ago by skymoo (Adam Mercer)

Resolution: fixed
Status: closedreopened

I'm still seeing 0.82 after running a sync, and 0.82 is the version thats in SVN

comment:6 Changed 14 years ago by markd@…

Sorry. Guess I didn't pull the rigger after all. It is now confirmed to be in and available via selfupdate. Say, do you have an opinion on this enhancement to the port? https://svn.macosforge.org/projects/macports/ticket/4805 Any chance you'd want to take over maintainership of this port?

comment:7 Changed 14 years ago by skymoo (Adam Mercer)

Thanks, I'm getting 0.87.4 now.

Regarding maintainership, I don't think I'd have time to do the job properly. The only thing I'd probably be able to do is to keep the port upto date with upstream and not address issues like #4805. But If you're going to be dropping it and no one else with more time is interested in taking it up then its an option.

comment:8 Changed 14 years ago by markd@…

Resolution: fixed
Status: reopenedclosed
Type: defectenhancement

No problem. But just FYI, to be maintainer of a port you don't need to be able to address issues like 4805. Since I don't know th app at all I just thought I'd ask. It is often not much more than passing on updates. But since you don't have a strong preference to do it and the app may not require many updates anyway no need to pursue it. Thanks for the update!

Note: See TracTickets for help on using tickets.