Opened 13 years ago

Closed 13 years ago

#9789 closed defect (fixed)

BUG: gnuchess-5.07 segfaults

Reported by: pierre@… Owned by: pmq@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: yves@…
Port:

Description

Hi Yves, gnuchess builds correctly, but crashes whenever it starts to think. Here's a simple transcript showing the problem:

queinnec@calliope:~$ gnuchess GNU Chess 5.07 Adjusting HashSize to 1024 slots Transposition table: Entries=1K Size=48K Pawn hash table: Entries=0K Size=28K White (1) : easy White (1) : new White (1) : post White (1) : depth 6 Search to a depth of 6 White (1) : go Thinking... Bus error

btw, I tried the current debian patch [1] but I get the exact same result. -- Pierre

[1] http://ftp.debian.org/debian/pool/main/g/gnuchess/gnuchess_5.07-4.diff.gz

Change History (4)

comment:1 Changed 13 years ago by yves@…

Resolution: wontfix
Status: newclosed

Yes, I know, but that's beyond my ability to fix. sorry. It does work in terminal mode, if I remember well.

comment:2 Changed 13 years ago by pmq@…

Resolution: wontfix
Status: closedreopened

comment:3 Changed 13 years ago by pmq@…

Owner: changed from macports-tickets@… to pmq@…
Status: reopenednew

comment:4 Changed 13 years ago by pmq@…

Resolution: fixed
Status: newclosed

Committed a fix.

Note: See TracTickets for help on using tickets.