Opened 14 years ago

Closed 14 years ago

#9922 closed defect (fixed)

libsdl_mixer 1.2.7 needs a lot of help

Reported by: scooter.phd@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

a) the code tries to include "SDL_config.h", which is apparently a non-existent header file if libsdl 1.2.7 is installed.

b) the code depends on MACOS and MACOSX to be defined in order to get native Apple midi features. gcc 4.0 doesn't define either of these manifest contants.

a lot of hand hacking required to get the nasty beastie to compile and install.

Change History (1)

comment:1 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: fixed
Status: newclosed

This installs well using the latest revision of everything. Marking as fixed.

Note: See TracTickets for help on using tickets.