Opened 13 years ago

Closed 10 years ago

#12750 closed defect (duplicate)

I cannot install help2man

Reported by: doupsy@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: Cc: markd@…
Port: help2man

Description (last modified by jmroot (Joshua Root))

I cannot install help2man. When I try, I have this :

sudo port -dv install help2man
Password:
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/help2man
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/help2man
DEBUG: Requested variant powerpc is not provided by port help2man.
DEBUG: Requested variant darwin is not provided by port help2man.
DEBUG: Requested variant macosx is not provided by port help2man.
DEBUG: Executing variant darwin_8 provides darwin_8
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/perl5.8
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/lang/perl5.8
DEBUG: Requested variant powerpc is not provided by port perl5.8.
DEBUG: Requested variant macosx is not provided by port perl5.8.
DEBUG: Executing variant darwin provides darwin
DEBUG: Executing variant darwin_8 provides darwin_8
DEBUG: Searching for dependency: perl5.8
DEBUG: Found Dependency: receipt exists for perl5.8
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/perl/p5-locale-gettext
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/perl/p5-locale-gettext
DEBUG: Requested variant powerpc is not provided by port p5-locale-gettext.
DEBUG: Requested variant darwin is not provided by port p5-locale-gettext.
DEBUG: Requested variant macosx is not provided by port p5-locale-gettext.
DEBUG: Searching for dependency: p5-locale-gettext
DEBUG: Found Dependency: receipt exists for p5-locale-gettext
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/gettext
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/devel/gettext
DEBUG: Requested variant powerpc is not provided by port gettext.
DEBUG: Requested variant darwin is not provided by port gettext.
DEBUG: Requested variant macosx is not provided by port gettext.
DEBUG: Searching for dependency: gettext
DEBUG: Found Dependency: receipt exists for gettext
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libiconv
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libiconv
DEBUG: Requested variant powerpc is not provided by port libiconv.
DEBUG: Requested variant darwin is not provided by port libiconv.
DEBUG: Requested variant macosx is not provided by port libiconv.
DEBUG: Executing variant darwin_8 provides darwin_8
DEBUG: Searching for dependency: libiconv
DEBUG: Found Dependency: receipt exists for libiconv
DEBUG: Skipping completed org.macports.main (help2man)
DEBUG: Skipping completed org.macports.fetch (help2man)
DEBUG: Skipping completed org.macports.checksum (help2man)
DEBUG: Skipping completed org.macports.extract (help2man)
DEBUG: Skipping completed org.macports.patch (help2man)
DEBUG: Skipping completed org.macports.configure (help2man)
DEBUG: Skipping completed org.macports.build (help2man)
--->  Staging help2man into destroot
. missing (directory not created: File exists)
./Applications missing (directory not created: File exists)
./Developer missing (directory not created: File exists)
./Library missing (directory not created: File exists)
DEBUG: Executing org.macports.destroot (help2man)
DEBUG: Environment: 
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.36.4" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot'
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/lib
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info
/usr/bin/install -c help2man /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
/usr/bin/install -c -m 644 ./help2man.1 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
/usr/bin/install -c -m 644 ./help2man.info \
    /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/help2man.info
if test -f /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/dir; \
then \
    /usr/bin/install-info --info-dir=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info \
        ./help2man.info; \
fi
/usr/bin/gcc-4.0  -o hacklocaledir.so -fPIC -bundle hacklocaledir.c 
hacklocaledir.c: In function '__open':
hacklocaledir.c:44: error: 'RTLD_NEXT' undeclared (first use in this function)
hacklocaledir.c:44: error: (Each undeclared identifier is reported only once
hacklocaledir.c:44: error: for each function it appears in.)
hacklocaledir.c: At top level:
hacklocaledir.c:113: warning: alias definitions not supported in Mach-O; ignored
make: *** [hacklocaledir.so] Error 1
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.36.4" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot " returned error 2
Command output: ./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/lib
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info
/usr/bin/install -c help2man /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
/usr/bin/install -c -m 644 ./help2man.1 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
/usr/bin/install -c -m 644 ./help2man.info \
    /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/help2man.info
if test -f /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/dir; \
then \
    /usr/bin/install-info --info-dir=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info \
        ./help2man.info; \
fi
/usr/bin/gcc-4.0  -o hacklocaledir.so -fPIC -bundle hacklocaledir.c 
hacklocaledir.c: In function '__open':
hacklocaledir.c:44: error: 'RTLD_NEXT' undeclared (first use in this function)
hacklocaledir.c:44: error: (Each undeclared identifier is reported only once
hacklocaledir.c:44: error: for each function it appears in.)
hacklocaledir.c: At top level:
hacklocaledir.c:113: warning: alias definitions not supported in Mach-O; ignored
make: *** [hacklocaledir.so] Error 1

Warning: the following items did not execute (for help2man): org.macports.activate org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

What is the problem ?

Thanks

Change History (7)

comment:1 Changed 13 years ago by nox@…

Keywords: make: *** [hacklocaledir.so] Error 1 removed
Milestone: Port Bugs

comment:2 Changed 13 years ago by markd@…

Cc: doupsy@… markd@… added

I can't duplicate this. What is your OS (10.3 or 10.4), platform (PPC or Intel), and Xcode version?

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

No feedback, therefore closing ticket. Works for me too. Please reopen ticket if problem still exists for you.

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:5 Changed 11 years ago by jmroot (Joshua Root)

Cc: doupsy@… removed
Description: modified (diff)
Port: help2man added

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: closedreopened

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: reopenedclosed

Actually a duplicate of #12336.

Note: See TracTickets for help on using tickets.