Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#12819 closed defect (fixed)

Latest ImageMagick and/or rb-rmagick breaks rmagick and gruff for RoR development

Reported by: davis@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 1.5.0
Keywords: rmagick Cc: ryandesign (Ryan Schmidt),
Port:

Description

Had rmagick and gruff working fine until I updated today. Now when I try to start rails using script/server or script/console, I get the following error:

[davis@mymac rails_app]$ script/console
Loading development environment.
dyld: NSLinkModule() error
dyld: Symbol not found: _HSLTransform
  Referenced from: /opt/local/lib/ruby/vendor_ruby/1.8/i686-darwin8.9.1/RMagick.bundle
  Expected in: flat namespace
Trace/BPT trap

[davis@mymac rails_app]$ port installed
The following ports are currently installed:
  apr @1.2.11_0 (active)
  apr @1.2.8_0
  apr @1.2.9_0
  apr-util @1.2.10_0 (active)
  apr-util @1.2.8_2
  autoconf @2.61_0
  autoconf @2.61_1 (active)
  bzip2 @1.0.4_1 (active)
  cvs @1.11.22_0 (active)
  db44 @4.4.20_1+darwin_8 (active)
  expat @2.0.0_1
  expat @2.0.1_0 (active)
  fontconfig @2.4.2_0+macosx
  fontconfig @2.4.2_1+macosx (active)
  freeimage @3.9.2-20070101_0 (active)
  freetype @2.3.5_0 (active)
  gettext @0.16.1_0 (active)
  ghostscript @8.60_0 (active)
  gzip @1.3.12_0+darwin_8 (active)
  help2man @1.36.4_0+darwin_8
  help2man @1.36.4_1+darwin_8 (active)
  ImageMagick @6.3.5-9_0+darwin_8 (active)
  jpeg @6b_1
  jpeg @6b_2 (active)
  libiconv @1.11_4+darwin_8
  libiconv @1.11_6+darwin_8 (active)
  libmikmod @3.2.0-beta2_0 (active)
  libogg @1.1.3_0
  libogg @1.1.3_1
  libogg @1.1.3_2 (active)
  libpng @1.2.16_0+darwin_8
  libpng @1.2.18_0+darwin_8
  libpng @1.2.20_0+darwin_8 (active)
  libsdl @1.2.11_0+darwin_8
  libsdl @1.2.12_0+darwin_8 (active)
  libsdl_image @1.2.5_1+darwin_8
  libsdl_image @1.2.6_0
  libsdl_image @1.2.6_1 (active)
  libtool @1.5.24_0
  libtool @1.5.24_1 (active)
  libvorbis @1.1.2_0
  libvorbis @1.2.0_0 (active)
  libwmf @0.2.8.4_0 (active)
  libxml2 @2.6.28_1
  libxml2 @2.6.30_0 (active)
  m4 @1.4.10_1 (active)
  m4 @1.4.9_0
  mysql5 @5.0.37_0+darwin_8+server
  mysql5 @5.0.45_0+darwin_8+server
  mysql5 @5.0.45_3+darwin_8+server (active)
  ncurses @5.5_1+darwin_8
  ncurses @5.6_0+darwin_8 (active)
  ncursesw @5.5_0+darwin_8
  ncursesw @5.6_0+darwin_8 (active)
  neon @0.26.3_0
  neon @0.26.3_1
  neon @0.26.4_0 (active)
  openssl @0.9.8e_0+darwin_8 (active)
  p5-locale-gettext @1.05_0 (active)
  perl5.8 @5.8.8_0+darwin_8 (active)
  pkgconfig @0.21_0
  pkgconfig @0.22_0 (active)
  py25-django-devel @0.96_1 (active)
  py25-hashlib @2.5.1_0 (active)
  py25-mysql @1.2.2_0 (active)
  py25-setuptools @0.6c6_0
  py25-setuptools @0.6c7_0 (active)
  python25 @2.5.1_1+darwin_8 (active)
  python25 @2.5_1+darwin_8
  rb-mysql @2.7.1_1
  rb-mysql @2.7.3_1 (active)
  rb-rmagick @1.14.1_0 (active)
  rb-rubygems @0.9.2_0
  rb-rubygems @0.9.4_0 (active)
  rb-termios @0.9.4_0 (active)
  readline @5.1.004_0
  readline @5.2.001_0
  readline @5.2.007_0 (active)
  ruby @1.8.6_0 (active)
  sqlite3 @3.3.13_0+darwin_8
  sqlite3 @3.3.15_0+darwin_8
  sqlite3 @3.4.1_0+darwin_8
  sqlite3 @3.4.2_0+darwin_8
  sqlite3 @3.4.2_1+darwin_8 (active)
  subversion @1.4.3_0+tools
  subversion @1.4.3_1+tools
  subversion @1.4.4_0+tools
  subversion @1.4.5_0+tools (active)
  tiff @3.8.2_0+darwin_8
  tiff @3.8.2_1+darwin_8+macosx (active)
  zlib @1.2.3_0
  zlib @1.2.3_1 (active)

This is on a MacBook (Core Duo 2) with OSX 10.4.10

Change History (9)

comment:1 Changed 13 years ago by nox@…

Cc: ryandesign@… added
Milestone: Port Bugs

comment:2 Changed 13 years ago by website@…

RMagick version 1.15.10 fixes this, and is compatible with ImageMagick 6.3.5-9. See http://rubyforge.org/forum/forum.php?forum_id=17480 for more information.

comment:3 Changed 13 years ago by yuri.leikind@…

When will RMagick version 1.15.10 be available in ports? Currently only 1.14.1 is available.

comment:4 Changed 13 years ago by afb@…

Upgraded, r31115.

comment:5 Changed 13 years ago by nox@…

So... why don't we close this ticket?

comment:6 Changed 13 years ago by afb@…

We're waiting for some feedback from someone that actually uses it...

comment:7 Changed 13 years ago by yuri.leikind@…

here is the feedback - I successfully compiled rmagick with imagemagick, I think the issue is resolved.

comment:8 Changed 13 years ago by nox@…

Resolution: fixed
Status: newclosed

comment:9 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.