Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#13174 closed defect (worksforme)

guile 1.8.3_0 does not build: warning: implicit declaration of function 'open64'

Reported by: immanuel@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 1.5.0
Keywords: Cc: o.e.moen@…, nox@…
Port: guile

Description (last modified by blb@…)

sudo port install guile gives the following error. I got guile to compile on my own machine, but that was a hack. The problem is that configure is selecting the 64bit file functions on macos.

fports.c: In function 'scm_open_file':
fports.c:364: warning: implicit declaration of function 'open64'
fports.c: At top level:
fports.c:614: error: syntax error before 'fport_seek_or_seek64'
fports.c:614: error: syntax error before 'off64_t'
fports.c:615: warning: return type defaults to 'int'
fports.c:615: warning: no previous prototype for 'fport_seek_or_seek64'
fports.c: In function 'fport_seek_or_seek64':
fports.c:616: error: 'port' undeclared (first use in this function)
fports.c:616: error: (Each undeclared identifier is reported only once
fports.c:616: error: for each function it appears in.)
fports.c:618: error: 'off64_t' undeclared (first use in this function)
fports.c:618: error: syntax error before 'rv'
fports.c:623: error: 'offset' undeclared (first use in this function)
fports.c:623: error: 'whence' undeclared (first use in this function)
fports.c:626: error: 'result' undeclared (first use in this function)
fports.c:626: error: 'rv' undeclared (first use in this function)
fports.c:626: warning: implicit declaration of function 'lseek64'
fports.c: In function 'fport_seek':
fports.c:677: error: 'off64_t' undeclared (first use in this function)
fports.c:677: error: syntax error before 'rv'
fports.c:678: error: 'rv' undeclared (first use in this function)
fports.c: In function 'scm_i_fport_truncate':
fports.c:711: warning: implicit declaration of function 'ftruncate64'
make[3]: *** [libguile_la-fports.lo] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Attachments (2)

Portfile (2.2 KB) - added by lorenz.schori@… 13 years ago.
Portfile with manually fixed HAVE_STAT64
no-dylib.diff (3.0 KB) - added by lorenz.schori@… 13 years ago.
use -module instead of -export-dynamic for loadable modules. not sure about that though

Download all attachments as: .zip

Change History (14)

comment:1 Changed 13 years ago by frstan@…

same error occurs when trying to upgrade to guile 1.8.3_0 from 1.8.1_2 on Leopard Intel

Changed 13 years ago by lorenz.schori@…

Attachment: Portfile added

Portfile with manually fixed HAVE_STAT64

Changed 13 years ago by lorenz.schori@…

Attachment: no-dylib.diff added

use -module instead of -export-dynamic for loadable modules. not sure about that though

comment:2 Changed 13 years ago by tomaz.solc@…

Your patch worked for me (guile 1.8.3_1, Leopard PPC). Thanks.

comment:3 Changed 13 years ago by wsiegrist@…

Component: infrastructureports
Owner: changed from kvv@… to mas@…

This is not an infrastructure issue. Reassigning to the maintainer.

comment:4 Changed 13 years ago by cssdev

Milestone: Port Bugs

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: mas@… deleted
Summary: guile does not install on macports 1.5guile 1.8.3_0 does not build: warning: implicit declaration of function 'open64'

Reassigning to nobody since guile has no maintainer. Changing summary since issue has nothing to do specifically with version 1.5 of MacPorts.

comment:6 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: o.e.moen@… added

comment:7 Changed 13 years ago by jmroot (Joshua Root)

Owner: set to macports-tickets@…

comment:8 Changed 12 years ago by nox@…

Does it still not work with guile 1.8.4?

comment:9 Changed 12 years ago by nox@…

Cc: nox@… added

Cc Me!

comment:10 Changed 12 years ago by dbevans (David B. Evans)

Keywords: guile removed
Port: guile added

guile 1.8.5 committed in r41744 builds without error on 10.4.11 ppc.

comment:11 Changed 12 years ago by blb@…

Description: modified (diff)
Resolution: worksforme
Status: newclosed

Closing, lack of response, 1.8.5 works for me on 10.5.5 Intel too.

comment:12 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.