Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13173 closed defect (fixed)

aqbanking 2.2.9 build: ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib

Reported by: jmauro@… Owned by: mas@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: aqbanking leopard gnucash Cc: petr.snyder@…, someguyonearth@…
Port:

Description

During the build for gnucash, the aqbanking module fails to build on a 10.5 (Leopard) OS. The error is:

ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib

It appears to be explained in the fink archives as a change in how OpenGL links in 10.5. The link is http://www.mail-archive.com/fink-users@lists.sourceforge.net/msg25742.html

I've tried, but I cannot seem to find a combination to fix it.

The build output is:

---> Building aqbanking with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_aqbanking/work/aqbanking-2.2.9" && make all " returned error 2 Command output: make[6]: Nothing to be done for `all'. Making all in dialogs make[6]: Nothing to be done for `all'. Making all in views make[6]: Nothing to be done for `all'. make[6]: Nothing to be done for `all-am'. Making all in qbanking Making all in lib make all-recursive Making all in widgets make all-am make[8]: Nothing to be done for `all-am'. Making all in dialogs make all-am make[8]: Nothing to be done for `all-am'. Making all in views make all-am make[8]: Nothing to be done for `all-am'. /bin/sh ../../../../libtool --tag=CXX --mode=link g++ -O2 -g -Wall -L/opt/local/lib -g -o testlib testlib.o libqbanking.la /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_aqbanking/work/aqbanking-2.2.9/src/libs/aqbanking/libaqbanking.la -lintl g++ -O2 -g -Wall -g -o .libs/testlib testlib.o -Wl,-bind_at_load -L/opt/local/lib ./.libs/libqbanking.dylib -L/usr/lib -L/sw/lib -L/opt/local/lib/qt3/lib /opt/local/lib/qt3/lib/libqt-mt.dylib -L/usr/X11R6/lib -lresolv -lz -lGL /usr/X11/lib/libXmu.6.2.0.dylib /opt/local/lib/libXrender.dylib /usr/X11/lib/libXrandr.2.0.0.dylib /usr/X11/lib/libXcursor.1.0.2.dylib /usr/X11/lib/libXinerama.1.0.0.dylib /opt/local/lib/libXft.dylib /opt/local/lib/libfreetype.dylib /opt/local/lib/libfontconfig.dylib /usr/X11/lib/libXext.6.4.0.dylib /usr/X11/lib/libX11.6.2.0.dylib -lm /usr/X11/lib/libSM.6.0.0.dylib /usr/X11/lib/libICE.6.3.0.dylib -ldl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_aqbanking/work/aqbanking-2.2.9/src/libs/aqbanking/.libs/libaqbanking.dylib /opt/local/lib/libgwenhywfar.dylib -lssl -lcrypto /opt/local/lib/libintl.dylib /opt/local/lib/libiconv.dylib -lc ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib collect2: ld returned 1 exit status make[7]: * [testlib] Error 1 make[6]: * [all-recursive] Error 1 make[5]: * [all] Error 2 make[4]: * [all-recursive] Error 1 make[3]: * [all-recursive] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: The following dependencies failed to build: aqbanking evince audiofile avahi dbus docbook-xml-4.1.2 xmlcatmgr xmlto docbook-xml-4.2 docbook-xsl getopt libxslt dbus-glib dbus-python25 py25-gobject python25 py25-numeric gdbm libdaemon py25-gdbm py25-gtk py25-cairo esound gconf intltool p5-xml-parser orbit2 libidl gnome-doc-utils docbook-xml docbook-xml-4.3 docbook-xml-4.4 docbook-xml-4.5 iso-codes py25-hashlib openssl py25-libxml2 scrollkeeper gnome-icon-theme icon-naming-utils p5-getopt-long p5-pathtools p5-xml-simple p5-test-simple p5-test-harness p5-xml-namespacesupport p5-xml-sax gnome-keyring libgcrypt libgpg-error gnome-vfs gnome-mime-data howl neon libart_lgpl libgnome libbonobo popt libgnomecanvas gail libgnomeui libbonoboui m4 nautilus eel gnome-desktop fribidi startup-notification gnome-menus libexif librsvg libcroco libgsf shared-mime-info poppler poppler-data gnucash-docs yelp firefox-x11 zip libgtkhtml goffice03 libgnomeprintui libgnomeprint bison libgnomecups pcre guile16 readline ncurses ncursesw libgtkhtml3 p5-finance-quote p5-crypt-ssleay p5-libwww-perl p5-compress-zlib p5-compress-raw-zlib p5-io-compress-base p5-scalar-list-utils p5-io-compress-zlib p5-html-parser p5-html-tagset p5-uri p5-datemanip p5-html-tableextract slib slib-guile16 Error: Status 1 encountered during processing.

Change History (12)

comment:1 Changed 13 years ago by jmauro@…

Figured it out:

Add the following line to the port file after configure.cflags-append configure.ldflags-append "-Wl,-dylib_file,/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib:/System/Library/Frameworks/OpenGL.framework/Versions/A/Libraries/libGL.dylib"

I do not know its effect on Tiger though since I only have a MacBook running leopard.

comment:2 Changed 13 years ago by scott@…

I can confirm the bug on my Leopard machine (MacBook Pro), and that the fix in the previous comment results in a successful build.

comment:3 Changed 13 years ago by cssdev

Cc: mas@… added

Add maintainer cc, but the port should be assigned to the correct maintainer registered in Trac. Is that mas@…?

comment:4 Changed 13 years ago by artooro@…

Thanks for the fix jmauro. Saved me the trouble of figuring it out. Now hopefully the maintainer deploys a fix soon.

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: mas@… removed
Milestone: Port Bugs
Owner: changed from macports-tickets@… to mas@…
Summary: aqbanking Fails to buildaqbanking 2.2.9 build: ld: cycle in dylib re-exports with /usr/X11R6/lib/libGL.dylib

Earth to maintainer...

comment:6 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: petr.snyder@… added

There is an Apple Developer Technical Q&A regarding this problem.

http://developer.apple.com/qa/qa2007/qa1567.html

comment:7 Changed 13 years ago by ryandesign (Ryan Schmidt)

Has duplicate #13577.

comment:8 Changed 13 years ago by jens.haeusser@…

This problem persists after the upgrade to 2.3.3 (#13685). I've opened a new ticket #13750.

comment:9 Changed 13 years ago by ryandesign (Ryan Schmidt)

There is no need to open a new ticket; we already have this one. I'll close #13750 as a duplicate. #13750 includes a fix.

comment:10 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: someguyonearth@… added

comment:11 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

I applied the fix from #13750 in r32444. Hopefully that'll fix the problem. Please wait 30 minutes, then "sudo port selfupdate", then "sudo port clean --work aqbanking", then "sudo port install aqbanking". If the problem persists, please reopen this ticket.

comment:12 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.